summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libcharon/Manifest1
-rw-r--r--dev-libs/libcharon/libcharon-4.8.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/libcharon/Manifest b/dev-libs/libcharon/Manifest
index 110aac1b7d4a..4a5081011238 100644
--- a/dev-libs/libcharon/Manifest
+++ b/dev-libs/libcharon/Manifest
@@ -1,2 +1,3 @@
DIST libcharon-4.6.1.tar.gz 145486 BLAKE2B 43a3bcddf128da9305711757b707394b5b0c23da27e27c3615d521e0af79683b2a525fefa7ae877581b56dae4c1dd7036c3189c17f8f86c92492b46e129a22b3 SHA512 43f7606529a933067bcb82a16e95d76f713a7847535887968c2933131d3197ec6127376e10c7d5f1debd218fc902962329fe22d4f9229b434a804daff94122cc
DIST libcharon-4.7.0.tar.gz 151221 BLAKE2B af9fe83e07303e1ff296b878c9745a329531a9957ad16a9b39b36e53f3f2275f850806b6d1a51638013c7148f3ee68b92489a67629a6026056a8c4ed3f2338b1 SHA512 690ce086bf8bba3eee2ce087d02ce00c23a7ac4079b0a2961c05cf75d461b0d5dee0c1f86ed769b50f1cd9ef83d8570a54f4fac628e0c19a5a593138292bc64c
+DIST libcharon-4.8.0.tar.gz 151223 BLAKE2B fe4d2901908367569b45c466d31ac6e290979a8bd39c84f9c3ceb3ed91e9d9f1a789703fa5006706e21d77bd46b3185571df3f6157c7722e3e35244d27e0231c SHA512 33d3e9aa4e356fbf1d41555cfe2a5470d8f02b1d4f59d83e1ba89236b5e4489a93bdf24fad6f9bd2b0f843c053c485a082f5ee57437862ac40522aa61280b19c
diff --git a/dev-libs/libcharon/libcharon-4.8.0.ebuild b/dev-libs/libcharon/libcharon-4.8.0.ebuild
new file mode 100644
index 000000000000..8d711b6d6bd4
--- /dev/null
+++ b/dev-libs/libcharon/libcharon-4.8.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit cmake python-single-r1
+
+MY_PN="libCharon"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libCharon"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="+client +dbus test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dbus? (
+ acct-group/ultimaker
+ acct-user/ultimaker
+ sys-apps/dbus
+ )"
+
+DEPEND="${PYTHON_DEPS}
+ test? (
+ $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_MULTI_USEDEP}]')
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ # use current python version, not the latest installed
+ # fix python install location
+ sed -i \
+ -e "s:find_package(Python3 3.4 REQUIRED:find_package(Python3 ${EPYTHON##python} EXACT REQUIRED:g" \
+ -e "s:lib\${LIB_SUFFIX}/python\${Python3_VERSION_MAJOR}\.\${Python3_VERSION_MINOR}/site-packages:$(python_get_sitedir):g" \
+ CMakeLists.txt || die
+
+ sed -i -e "s:/usr/lib/python3/dist-packages/Charon/Service/main.py:$(python_get_sitedir)/Charon/Service/main.py:g" service/charon.service || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_CLIENT=$(usex client ON OFF)
+ -DINSTALL_SERVICE=$(usex dbus ON OFF)
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ python_optimize "${D}/usr/$(get_libdir)"
+}
+
+pkg_postinst() {
+ if use dbus ; then
+ elog "To start the Charon File Metadata service at boot, add it to the default runlevel with:"
+ elog " systemctl enable charon"
+ fi
+}