summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-1.19.0.ebuild2
-rw-r--r--app-crypt/acme/acme-1.20.0.ebuild39
3 files changed, 41 insertions, 1 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index ba831c78628a..d2519ac78a81 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.18.0.tar.gz 1332615 BLAKE2B eb086710b943893025d6e1091470ca02de074232372f4c9fa21fa83a347fe54df988b9553c8cf6afd6e166b8c464d595171984c984008a872e16c0179bb774b2 SHA512 94b16ba0586e0f5d3036280c68f9976c25889ca48fbbe7aded41f0d9feba2300a3f0ff8fe321b39d8642bcdd874c7332cf2acb3187b5869fe415831f58a75a7b
DIST certbot-1.19.0.tar.gz 1338653 BLAKE2B b6ed909da2aed9853cf3dc6b936c513f33a127548ee30ac45a32a682141c5e4e79401ea328b7caf4e28d1d85aa2a9831e93deaa26c93216708a33be465dc8387 SHA512 2c1beb8c06299b9003fafd970cd3e977db85c4e84f1bf710166b7a99035b5c43a2a222d8d51513ac595255dd8eda02a1fb834c01ce68921927715c880052536e
+DIST certbot-1.20.0.tar.gz 1339066 BLAKE2B 01278a53ea7166037c039d270ddd11a10c0570a9f038571dc6791e51f214fbff1589371b40c0dc73cbc18ed2005cfc231452bd00b039841a09ddb3c65d4ab122 SHA512 d35b2574811ac896ad119355be3a901438400e81a67388bd93290c4e7e9f6fa60dad99b51bc9bac7a7ac60714ed8bb6f60f522ce1a1a169886d0a15f0d0e371b
diff --git a/app-crypt/acme/acme-1.19.0.ebuild b/app-crypt/acme/acme-1.19.0.ebuild
index c3e47e636d10..433e9adde4d9 100644
--- a/app-crypt/acme/acme-1.19.0.ebuild
+++ b/app-crypt/acme/acme-1.19.0.ebuild
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999* ]]; then
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
S=${WORKDIR}/certbot-${PV}/acme
fi
diff --git a/app-crypt/acme/acme-1.20.0.ebuild b/app-crypt/acme/acme-1.20.0.ebuild
new file mode 100644
index 000000000000..0893747ea29d
--- /dev/null
+++ b/app-crypt/acme/acme-1.20.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest