summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/probe/probe-2.13.110909.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/sci-chemistry/probe/probe-2.13.110909.ebuild b/sci-chemistry/probe/probe-2.13.110909.ebuild
index 66b1ac8c56da..628e2654bd30 100644
--- a/sci-chemistry/probe/probe-2.13.110909.ebuild
+++ b/sci-chemistry/probe/probe-2.13.110909.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_P="${PN}.${PV}"
@@ -11,23 +11,21 @@ DESCRIPTION="Evaluates atomic packing within or between molecules"
HOMEPAGE="http://kinemage.biochem.duke.edu/software/probe.php"
SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/probe/${MY_P}.src.zip"
-SLOT="0"
LICENSE="richardson"
+SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/unzip"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}.src"
-S="${WORKDIR}"/${MY_P}.src
+PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )
-src_prepare() {
- epatch "${FILESDIR}"/${P}-as-needed.patch
+src_configure() {
tc-export CC
}
src_install() {
- dobin "${S}"/probe
- dodoc "${S}"/README*
+ dobin probe
+ einstalldocs
}