summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/matterhook/Manifest1
-rw-r--r--dev-python/matterhook/matterhook-0.1.ebuild21
-rw-r--r--dev-python/matterhook/metadata.xml13
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/matterhook/Manifest b/dev-python/matterhook/Manifest
new file mode 100644
index 000000000000..e3d38bb3f442
--- /dev/null
+++ b/dev-python/matterhook/Manifest
@@ -0,0 +1 @@
+DIST matterhook-0.1.tar.gz 3150 BLAKE2B 841b64875d3ecc55c5056a15e07e8c46ac13ec48f1fd2752ec0c3934608172c8970cc4ad6ce984e227bef811aaee9ca2fc352afbf4e4925a6930adf798edbdd3 SHA512 1c9d264fb80b7d6d746f8379c869903e80f0b4a134efb3ca571630fdbe53eb7b1ac244470f7c2f8229cfe54e7597594427e253f35f0b103fc4c4123a935c5193
diff --git a/dev-python/matterhook/matterhook-0.1.ebuild b/dev-python/matterhook/matterhook-0.1.ebuild
new file mode 100644
index 000000000000..36526446b338
--- /dev/null
+++ b/dev-python/matterhook/matterhook-0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interact with Mattermost incoming webhooks easily"
+HOMEPAGE="https://github.com/numberly/matterhook"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/matterhook/metadata.xml b/dev-python/matterhook/metadata.xml
new file mode 100644
index 000000000000..046d30161928
--- /dev/null
+++ b/dev-python/matterhook/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ultrabug@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">numberly/matterhook</remote-id>
+ </upstream>
+</pkgmetadata>