summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-wm/hyprland/files/bash-completion-fix-0.39.1.patch22
-rw-r--r--gui-wm/hyprland/hyprland-0.39.1-r1.ebuild (renamed from gui-wm/hyprland/hyprland-0.39.1.ebuild)6
2 files changed, 28 insertions, 0 deletions
diff --git a/gui-wm/hyprland/files/bash-completion-fix-0.39.1.patch b/gui-wm/hyprland/files/bash-completion-fix-0.39.1.patch
new file mode 100644
index 000000000000..fe48ce45dd3a
--- /dev/null
+++ b/gui-wm/hyprland/files/bash-completion-fix-0.39.1.patch
@@ -0,0 +1,22 @@
+https://github.com/hyprwm/Hyprland/pull/5653
+
+--- a/hyprctl/meson.build
++++ b/hyprctl/meson.build
+@@ -2,6 +2,6 @@ executable('hyprctl', 'main.cpp',
+ install: true
+ )
+
+-install_data('hyprctl.bash', install_dir: join_paths(get_option('datadir'), 'bash-completion'), install_tag: 'runtime', rename: 'hyprctl')
++install_data('hyprctl.bash', install_dir: join_paths(get_option('datadir'), 'bash-completion/completions'), install_tag: 'runtime', rename: 'hyprctl')
+ install_data('hyprctl.fish', install_dir: join_paths(get_option('datadir'), 'fish/vendor_completions.d'), install_tag: 'runtime')
+ install_data('hyprctl.zsh', install_dir: join_paths(get_option('datadir'), 'zsh/site-functions'), install_tag: 'runtime', rename: '_hyprctl')
+--- a/hyprpm/src/meson.build
++++ b/hyprpm/src/meson.build
+@@ -9,6 +9,6 @@ executable('hyprpm', src,
+ install : true
+ )
+
+-install_data('../hyprpm.bash', install_dir: join_paths(get_option('datadir'), 'bash-completion'), install_tag: 'runtime', rename: 'hyprpm')
++install_data('../hyprpm.bash', install_dir: join_paths(get_option('datadir'), 'bash-completion/completions'), install_tag: 'runtime', rename: 'hyprpm')
+ install_data('../hyprpm.fish', install_dir: join_paths(get_option('datadir'), 'fish/vendor_completions.d'), install_tag: 'runtime')
+ install_data('../hyprpm.zsh', install_dir: join_paths(get_option('datadir'), 'zsh/site-functions'), install_tag: 'runtime', rename: '_hyprpm')
diff --git a/gui-wm/hyprland/hyprland-0.39.1.ebuild b/gui-wm/hyprland/hyprland-0.39.1-r1.ebuild
index 3368e4aa15c2..6b1a6eff78b2 100644
--- a/gui-wm/hyprland/hyprland-0.39.1.ebuild
+++ b/gui-wm/hyprland/hyprland-0.39.1-r1.ebuild
@@ -95,6 +95,12 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ # https://bugs.gentoo.org/930132
+ # https://github.com/hyprwm/Hyprland/pull/5653
+ "${FILESDIR}/bash-completion-fix-0.39.1.patch"
+)
+
pkg_setup() {
[[ ${MERGE_TYPE} == binary ]] && return