summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/ptex/Manifest1
-rw-r--r--media-libs/ptex/files/ptex-2.3.0-cxx11.patch12
-rw-r--r--media-libs/ptex/ptex-2.3.0.ebuild33
3 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/ptex/Manifest b/media-libs/ptex/Manifest
index a49cd522665e..f7c5d0f3e48d 100644
--- a/media-libs/ptex/Manifest
+++ b/media-libs/ptex/Manifest
@@ -1 +1,2 @@
DIST ptex-2.1.28.tar.gz 305327 BLAKE2B 4a91b08ae326e8ed8d420022c693ea60cb21908380b8c49a7672771686f9dd2ef05151b7d43755bc63ab6624db772c2b53d1ffdcdea9c1dff7627cc3fe0f3b15 SHA512 ddce3c79f14d196e550c1e8a5b371482f88190cd667a2e2aa84601de1639f7cabb8571c1b3a49b48df46ce550d27088a00a67b1403c3bfec2ed73437c3dca3e8
+DIST ptex-2.3.0.tar.gz 306462 BLAKE2B 790e3623ce6ebae2dfd8884d8e19e62395c54432289d88bdcf3a01c8ae1ef752ca88869357ac1e4657d59f1ca73d311a3fb9a08efe4e145ca259eff93d8a3b6a SHA512 2d9d320e4205236a4eff05ec3c67d085624809ebefa89fa3b943d18a8b2b6a5f61c022a4cc4363a7c6ceccfb9eac4f8738dff2e90a3355814f2c4ff096c09992
diff --git a/media-libs/ptex/files/ptex-2.3.0-cxx11.patch b/media-libs/ptex/files/ptex-2.3.0-cxx11.patch
new file mode 100644
index 000000000000..f0b600091377
--- /dev/null
+++ b/media-libs/ptex/files/ptex-2.3.0-cxx11.patch
@@ -0,0 +1,12 @@
+diff -purN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2016-04-04 18:14:05.000000000 +0100
++++ b/CMakeLists.txt 2017-02-13 22:59:10.000000000 +0000
+@@ -16,7 +16,7 @@ else ()
+ endif ()
+
+ if (NOT WIN32)
+- set(CMAKE_CXX_FLAGS "-std=c++98 -Wall -Wextra -pedantic ${CMAKE_CXX_FLAGS}")
++ set(CMAKE_CXX_FLAGS "-std=c++11 -Wall -Wextra -pedantic ${CMAKE_CXX_FLAGS}")
+ endif ()
+
+ if(MSVC)
diff --git a/media-libs/ptex/ptex-2.3.0.ebuild b/media-libs/ptex/ptex-2.3.0.ebuild
new file mode 100644
index 000000000000..b3cec3d387bf
--- /dev/null
+++ b/media-libs/ptex/ptex-2.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Per-Face Texture Mapping for Production Rendering"
+HOMEPAGE="http://ptex.us/"
+SRC_URI="https://github.com/wdas/ptex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-cxx11.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/html"
+ -DPTEX_BUILD_STATIC_LIBS=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}