summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/udpcast/Manifest1
-rw-r--r--net-misc/udpcast/files/udpcast-20200328-gentoo.patch12
-rw-r--r--net-misc/udpcast/udpcast-20200328.ebuild32
3 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/udpcast/Manifest b/net-misc/udpcast/Manifest
index 529023d5d4a4..5a24e62628d3 100644
--- a/net-misc/udpcast/Manifest
+++ b/net-misc/udpcast/Manifest
@@ -1 +1,2 @@
DIST udpcast-20120424.tar.bz2 138955 BLAKE2B 4ba16b9ff86f32bf1f2b07d521fbe1ef05774f0418362eb02fb06eaf84083e1f5e1ee5fc0a675f65b510d9adefcdb0d627bf6f104d5ce501d074517cbd312d6d SHA512 b28ada43f9f3cba498ffff3032cff6a673584836439275604c1201a18fe2e37f2c847a48b72783065b1656a7a2f9e9739d8a376e90df8b05749bc2e2f64278de
+DIST udpcast-20200328.tar.gz 169252 BLAKE2B df760dea814fabf951a65dc191a88355dec864d9c0f1be99ea60c742862d0b9944e51a45dd462ffce5c4b56a8d94f719796e3c725b42edae8cb9a19b1d3bc147 SHA512 b1ce4f0cade5db6bc69d3a154c354565675f44e97f9e3d90152f9594fd4f17fff2891eb1cb8d73c59e0d24eeb85e485e96b7a64fa9f1b6d2f005c4cece377bc7
diff --git a/net-misc/udpcast/files/udpcast-20200328-gentoo.patch b/net-misc/udpcast/files/udpcast-20200328-gentoo.patch
new file mode 100644
index 000000000000..529c31f7f7c8
--- /dev/null
+++ b/net-misc/udpcast/files/udpcast-20200328-gentoo.patch
@@ -0,0 +1,12 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -30,8 +30,7 @@
+
+ # For additional warnings & checks, add -Wstrict-prototypes -Wshadow to the
+ # following:
+-CFLAGS +=-Wall -DBB_FEATURE_UDPCAST_FEC -DUSE_SYSLOG -DUSE_ASSEMBLER -O6
+-LDFLAGS +=-s
++CFLAGS +=-Wall -DBB_FEATURE_UDPCAST_FEC -DUSE_SYSLOG
+ LIBS +=@LIBS@
+
+ BUSYBOX=../udp-busybox/busybox
diff --git a/net-misc/udpcast/udpcast-20200328.ebuild b/net-misc/udpcast/udpcast-20200328.ebuild
new file mode 100644
index 000000000000..ecb6e1be2332
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20200328.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="https://www.udpcast.linux.lu/"
+SRC_URI="https://www.udpcast.linux.lu/download/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hardened"
+
+BDEPEND="
+ dev-lang/perl
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-20200328-gentoo.patch
+)
+
+src_configure() {
+ use hardened || append-cppflags -DUSE_ASSEMBLER
+
+ default
+}
+
+src_install() {
+ default
+ dodoc *.txt
+}