summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/requests-cache/requests-cache-0.4.12-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/requests-cache/requests-cache-0.4.12-r1.ebuild b/dev-python/requests-cache/requests-cache-0.4.12-r1.ebuild
new file mode 100644
index 000000000000..9315a80d30ac
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.4.12-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1
+
+HOMEPAGE="https://pypi.org/project/requests-cache/"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+# Portage only has versions of request >= minimum border
+RDEPEND=">=dev-python/requests-2.6[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Testsuite excels in tests connecting to the network via local server daemons
+#distutils_enable_tests setup.py
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}