summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/doom-modeline/Manifest1
-rw-r--r--app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild41
-rw-r--r--app-emacs/doom-modeline/files/50doom-modeline-gentoo.el2
-rw-r--r--app-emacs/doom-modeline/metadata.xml13
4 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/doom-modeline/Manifest b/app-emacs/doom-modeline/Manifest
new file mode 100644
index 000000000000..e9ff737913e2
--- /dev/null
+++ b/app-emacs/doom-modeline/Manifest
@@ -0,0 +1 @@
+DIST doom-modeline-3.3.2.tar.gz 61363 BLAKE2B 2b80748265f911954e1726dc30e6bacf4ba7ffb6eb589e8f67c366b818e212376039eb025d380937b327f7d3d4a980ec6bfe0589ac38af1e0d678a8f6038b97f SHA512 ff0b41c5f8dc7e5a4a5bccaa710b445a1894948893cd7dea6c564d3a9b1be5cd7cd005e6a28613a6800526d5158faebfef51d21b9e911d97416821210954f0b3
diff --git a/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild b/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild
new file mode 100644
index 000000000000..8699aa390639
--- /dev/null
+++ b/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Fancy and fast mode-line for Emacs inspired by minimalism design"
+HOMEPAGE="https://seagle0128.github.io/doom-modeline/
+ https://github.com/seagle0128/doom-modeline/"
+SRC_URI="https://github.com/seagle0128/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ app-emacs/all-the-icons
+ app-emacs/compat
+ app-emacs/shrink-path
+"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -L . -L test \
+ -l test/${PN}-core-test.el \
+ -l test/${PN}-env-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
diff --git a/app-emacs/doom-modeline/files/50doom-modeline-gentoo.el b/app-emacs/doom-modeline/files/50doom-modeline-gentoo.el
new file mode 100644
index 000000000000..0dd9efab6129
--- /dev/null
+++ b/app-emacs/doom-modeline/files/50doom-modeline-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "doom-modeline-autoloads" nil t)
diff --git a/app-emacs/doom-modeline/metadata.xml b/app-emacs/doom-modeline/metadata.xml
new file mode 100644
index 000000000000..e8b3def7a3b9
--- /dev/null
+++ b/app-emacs/doom-modeline/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/seagle0128/doom-modeline/issues/</bugs-to>
+ <remote-id type="github">seagle0128/doom-modeline</remote-id>
+ </upstream>
+</pkgmetadata>