summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/shish/shish-0.7_pre3-r1.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/app-shells/shish/shish-0.7_pre3-r1.ebuild b/app-shells/shish/shish-0.7_pre3-r1.ebuild
index 11fee89ec6d7..10c7d469d2dc 100644
--- a/app-shells/shish/shish-0.7_pre3-r1.ebuild
+++ b/app-shells/shish/shish-0.7_pre3-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -11,6 +11,7 @@ MY_P="${PN}-${MY_PV}"
DESCRIPTION="The diet shell"
HOMEPAGE="http://www.blah.ch/shish/"
SRC_URI="http://www.blah.ch/${PN}/pkg/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
@@ -20,15 +21,11 @@ IUSE="debug diet"
DEPEND="diet? ( dev-libs/dietlibc )"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
-
DOCS=( AUTHORS BUGS ChangeLog README TODO )
-pkg_setup() {
- use diet && export CC="diet $(tc-getCC) -nostdinc"
-}
-
src_prepare() {
+ default
+
# Respect CFLAGS, bug #439974
sed -i \
-e '/CFLAGS="$CFLAGS/d' \
@@ -37,6 +34,8 @@ src_prepare() {
}
src_configure() {
+ use diet && export CC="diet $(tc-getCC) -nostdinc"
+
econf \
$(use_enable debug) \
--disable-quiet # bug 439974
@@ -53,7 +52,7 @@ src_install() {
}
pkg_postinst() {
- einfo "Updating ${ROOT}etc/shells"
- ( grep -v "^/bin/shish$" "${ROOT}"etc/shells; echo "/bin/shish" ) > "${T}"/shells
- mv -f "${T}"/shells "${ROOT}"etc/shells
+ einfo "Updating ${EROOT}/etc/shells"
+ ( grep -v "^/bin/shish$" "${EROOT}"/etc/shells; echo "/bin/shish" ) > "${T}"/shells
+ mv -f "${T}"/shells "${EROOT}"/etc/shells
}