summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/frei0r-plugins/Manifest1
-rw-r--r--media-plugins/frei0r-plugins/files/frei0r-plugins-1.4-opencv3.patch64
-rw-r--r--media-plugins/frei0r-plugins/frei0r-plugins-1.4.ebuild65
3 files changed, 0 insertions, 130 deletions
diff --git a/media-plugins/frei0r-plugins/Manifest b/media-plugins/frei0r-plugins/Manifest
index 10688dfeafa9..ff322fb1ca6a 100644
--- a/media-plugins/frei0r-plugins/Manifest
+++ b/media-plugins/frei0r-plugins/Manifest
@@ -1,3 +1,2 @@
DIST frei0r-plugins-1.3.tar.gz 1092809 SHA256 b25da901115aa7f960cf5e541057266fddf132a7521d628e6cb344c9f16c0236 SHA512 3fcbdb61b656db42b841df6485ca06e2fe2bb8ca16dc054f9154408f843c4170454f8b9fc619b49989f6da9990b67eb7ac6b548dd0fbfb560fdb0f2789346f90 WHIRLPOOL d79a14eae912bd9739b498c7e4d2949529f3e212835a337023bd9760bc9a1dbf239fb4e8cb7f038060d945932df725559fbf283c6362e2777d171126859eff05
-DIST frei0r-plugins-1.4.tar.gz 1164909 SHA256 8470fcabde9f341b729be3be16385ffc8383d6f3328213907a43851b6e83be57 SHA512 48e5da48a8886242bc5f38911f943d28d507d802076f5fcd2b5c9adc29ed40cb37f30316d4f4c253d279f17eb00c6acad47a7be3aeeec0def7a4aca1130b34fa WHIRLPOOL 6245799e4c56e80ca75db0a75836912412b7b91d55719a5d1d76c27f11a1df0f3ca8d3106903b6535a250cd5579be981bf8b01373c2bca7db1cf2857e449eb5e
DIST frei0r-plugins-1.5.0.tar.gz 1519006 SHA256 781cf84a6c2a9a3252f54d2967b57f6de75a31fc1684371e112638c981f72b60 SHA512 9be0384421ff5ac9000dcda9acefb5cb2b6dc05ea72d9771fae990cb5fad4424dcef8dd15c1e5031a89169f914af8c7a30e47934ad007a3bc0150f3c005bc6bf WHIRLPOOL c582118da0d832edd10bf3e4473edb5ff352d67d723d84381befda0cee7deaaeb5f200b5db49603055d620921669d9e0346a7654db2f12e8d922419e7456eaf3
diff --git a/media-plugins/frei0r-plugins/files/frei0r-plugins-1.4-opencv3.patch b/media-plugins/frei0r-plugins/files/frei0r-plugins-1.4-opencv3.patch
deleted file mode 100644
index d6d96b047296..000000000000
--- a/media-plugins/frei0r-plugins/files/frei0r-plugins-1.4-opencv3.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-diff -ur a/frei0r-plugins-1.4/src/filter/facedetect/facedetect.c b/frei0r-plugins-1.4/src/filter/facedetect/facedetect.c
---- a/frei0r-plugins-1.4/src/filter/facedetect/facedetect.c 2013-02-24 15:43:22.000000000 +0200
-+++ b/frei0r-plugins-1.4/src/filter/facedetect/facedetect.c 2015-12-19 12:27:05.984180725 +0200
-@@ -211,8 +211,13 @@
-
- double scale = 1.3;
- IplImage* gray = cvCreateImage( cvSize(img->width,img->height), 8, 1 );
-+#if (CV_VERSION_EPOCH != 2)
-+ IplImage* small_img = cvCreateImage( cvSize( cvRound ((double)img->width/scale),
-+ cvRound ((double)img->height/scale)),
-+#else
- IplImage* small_img = cvCreateImage( cvSize( cvRound (img->width/scale),
- cvRound (img->height/scale)),
-+#endif
- 8, 1 );
- int i;
-
-diff -ur a/frei0r-plugins-1.4/src/filter/facedetect/facedetect.cpp b/frei0r-plugins-1.4/src/filter/facedetect/facedetect.cpp
---- a/frei0r-plugins-1.4/src/filter/facedetect/facedetect.cpp 2013-02-24 15:43:22.000000000 +0200
-+++ b/frei0r-plugins-1.4/src/filter/facedetect/facedetect.cpp 2015-12-19 12:24:00.023349871 +0200
-@@ -259,11 +259,19 @@
- {
- double scale = this->scale == 0? 1.0 : this->scale;
- CvScalar colors[5] = {
-+#if (CV_VERSION_EPOCH != 2)
-+ CvScalar(cvRound(color[0].r * 255), cvRound(color[0].g * 255), cvRound(color[0].b * 255), cvRound(alpha * 255)),
-+ CvScalar(cvRound(color[1].r * 255), cvRound(color[1].g * 255), cvRound(color[1].b * 255), cvRound(alpha * 255)),
-+ CvScalar(cvRound(color[2].r * 255), cvRound(color[2].g * 255), cvRound(color[2].b * 255), cvRound(alpha * 255)),
-+ CvScalar(cvRound(color[3].r * 255), cvRound(color[3].g * 255), cvRound(color[3].b * 255), cvRound(alpha * 255)),
-+ CvScalar(cvRound(color[4].r * 255), cvRound(color[4].g * 255), cvRound(color[4].b * 255), cvRound(alpha * 255)),
-+#else
- {{cvRound(color[0].r * 255), cvRound(color[0].g * 255), cvRound(color[0].b * 255), cvRound(alpha * 255)}},
- {{cvRound(color[1].r * 255), cvRound(color[1].g * 255), cvRound(color[1].b * 255), cvRound(alpha * 255)}},
- {{cvRound(color[2].r * 255), cvRound(color[2].g * 255), cvRound(color[2].b * 255), cvRound(alpha * 255)}},
- {{cvRound(color[3].r * 255), cvRound(color[3].g * 255), cvRound(color[3].b * 255), cvRound(alpha * 255)}},
- {{cvRound(color[4].r * 255), cvRound(color[4].g * 255), cvRound(color[4].b * 255), cvRound(alpha * 255)}},
-+#endif
- };
-
- for (int i = 0; i < (objects ? objects->total : 0); i++)
-@@ -287,14 +295,23 @@
- }
- case 1:
- {
-+#if (CV_VERSION_EPOCH != 2)
-+ CvBox2D box = CvBox2D(CvPoint2D32f(center.x, center.y), CvSize2D32f(r->width / scale, (r->height / scale) * 1.2), 90);
-+#else
- CvBox2D box = {{center.x, center.y}, {r->width / scale, (r->height / scale) * 1.2}, 90};
-+#endif
- cvEllipseBox(image, box, colors[i % 5], thickness, linetype);
- break;
- }
- case 2:
- {
-+#if (CV_VERSION_EPOCH != 2)
-+ CvPoint pt1 = CvPoint(r->x / scale, r->y / scale);
-+ CvPoint pt2 = CvPoint((r->x + r->width) / scale, (r->y + r->height) / scale);
-+#else
- CvPoint pt1 = {r->x / scale, r->y / scale};
- CvPoint pt2 = {(r->x + r->width) / scale, (r->y + r->height) / scale};
-+#endif
- cvRectangle(image, pt1, pt2, colors[i % 5], thickness, linetype);
- break;
- }
diff --git a/media-plugins/frei0r-plugins/frei0r-plugins-1.4.ebuild b/media-plugins/frei0r-plugins/frei0r-plugins-1.4.ebuild
deleted file mode 100644
index 93a9bee644e9..000000000000
--- a/media-plugins/frei0r-plugins/frei0r-plugins-1.4.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-inherit cmake-utils multilib
-
-DESCRIPTION="A minimalistic plugin API for video effects"
-HOMEPAGE="http://www.dyne.org/software/frei0r/"
-SRC_URI="http://files.dyne.org/frei0r/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="doc +facedetect +scale0tilt"
-
-RDEPEND="x11-libs/cairo
- facedetect? ( >=media-libs/opencv-2.3.0 )
- scale0tilt? ( >=media-libs/gavl-1.2.0 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-DOCS=( AUTHORS ChangeLog README TODO )
-
-src_prepare() {
- local f=CMakeLists.txt
-
- sed -i \
- -e '/set(CMAKE_C_FLAGS/d' \
- -e "/LIBDIR.*frei0r-1/s:lib:$(get_libdir):" \
- ${f} || die
-
- # https://bugs.gentoo.org/show_bug.cgi?id=555782
- epatch "${FILESDIR}/${P}-opencv3.patch"
-
- # https://bugs.gentoo.org/418243
- sed -i \
- -e '/set.*CMAKE_C_FLAGS/s:"): ${CMAKE_C_FLAGS}&:' \
- src/filter/*/${f} || die
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use "!facedetect" "WITHOUT_OPENCV" )
- $(cmake-utils_use "!scale0tilt" "WITHOUT_GAVL" )
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- if use doc; then
- pushd doc
- doxygen || die
- popd
- fi
-}
-
-src_install() {
- cmake-utils_src_install
-
- use doc && dohtml -r doc/html
-}