summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-testinfra/Manifest1
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-7.0.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 678fe70ff03e..94ade6e95fc2 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1 +1,2 @@
DIST pytest-testinfra-6.8.0.tar.gz 78611 BLAKE2B ab1f9732db6a5d88730f4989cc47dc2086844f9809754d9f7811a8f0f092cf3d1e6f48fac2596200bf8e354cfd4aa3dc767bc21139267813141c9522d2116453 SHA512 e0c044430ffae1772b937b405572ef05b6177a645aff7b96e1f779d4f68449241757efae137a03ea8aec28db5f91c0e71574ab52aebef0052ca99ea0ca08db23
+DIST pytest-testinfra-7.0.0.tar.gz 79296 BLAKE2B b0870cbf466627daff0ed6a3063c15c9b725fab4009fc24c3779b56765901e6b8d3a42fce429f1e42151b78d61f52c38955772e562c74d78c717a61a5fe74f04 SHA512 507d7a434c2eb159e2c36b1be3d447e386d3a4e614f2717ed8add456358f644c18f801db6774a4854e4ec7936643febd332aa4096ab26ae0080aceeff420c78e
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-7.0.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-7.0.0.ebuild
new file mode 100644
index 000000000000..5e4cec65cf58
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-7.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-testinfra/
+ https://pypi.org/project/pytest-testinfra/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# Ansible is called via its CLI
+# which(1) is used as fallback when `command -v ...` returns 127
+# (which e.g. happens when dash is used as /bin/sh)
+# https://github.com/pytest-dev/pytest-testinfra/issues/668
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible
+ app-admin/salt[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ sys-apps/which
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}