summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/phalanx/phalanx-22-r1.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/games-board/phalanx/phalanx-22-r1.ebuild b/games-board/phalanx/phalanx-22-r1.ebuild
index cb72a63812f8..36eae23cc9df 100644
--- a/games-board/phalanx/phalanx-22-r1.ebuild
+++ b/games-board/phalanx/phalanx-22-r1.ebuild
@@ -1,30 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit toolchain-funcs
-MY_PN="Phalanx"
-MY_PV="XXII"
-MY_P="${MY_PN}-${MY_PV}"
+MY_P="${PN^}-XXII"
-DESCRIPTION="A chess engine suitable for beginner and intermediate players"
+DESCRIPTION="Chess engine suitable for beginner and intermediate players"
HOMEPAGE="http://phalanx.sourceforge.net/"
SRC_URI="mirror://sourceforge/phalanx/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
src_compile() {
# configure is not used in the project; confs are in Makefile,
# and here we override them:
local define="-DGNUFUN" myvar
for myvar in "PBOOK" "SBOOK" "LEARN" ; do
- define="${define} -D${myvar}_DIR=\"\\\"/usr/share/${PN}\\\"\""
+ define="${define} -D${myvar}_DIR=\"\\\"${EPREFIX}/usr/share/${PN}\\\"\""
done
emake \
DEFINES="${define}" \
@@ -35,7 +32,9 @@ src_compile() {
src_install() {
dobin phalanx
+
insinto /usr/share/${PN}
doins pbook.phalanx sbook.phalanx learn.phalanx
+
einstalldocs
}