summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apache/passenger/Manifest1
-rw-r--r--www-apache/passenger/passenger-6.0.5.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/www-apache/passenger/Manifest b/www-apache/passenger/Manifest
index d1af92c0346f..ec0e8dd7a654 100644
--- a/www-apache/passenger/Manifest
+++ b/www-apache/passenger/Manifest
@@ -1,2 +1,3 @@
DIST passenger-6.0.2.tar.gz 7204982 BLAKE2B 056f85f88e49ca7dcfe37d1d1003beaa5325259a130b44aa60a319d36987c901b0a8a188998d38b68f3d396a71df0db8b8fc9562e58327b61a712dc39fb7ce1e SHA512 05a1c598588ad96864ef81ff8bc45535b3cb35c0f4840f16b93d39c0ece94378e806d967190a3d69b28b37d463624955bb45970459cf8febb258d8fd135e97f2
DIST passenger-6.0.4.tar.gz 7347803 BLAKE2B 2e367b8dd0ace6a2773de92b3237821625190f2ae52fd11a1a3c47230d24affe1f9d161ef0346210cc91a21ae3a58f40f796063796399da0d133d6b0a261f52c SHA512 dd3398bece50c9da6029a5a9d98de2bed2e33a92f49fc776fe2b8f80f4a47e36d8a716c12f2f74d9611de5aa04981ddf680fc29a37f5b1860731a6f6e8390c81
+DIST passenger-6.0.5.tar.gz 7347149 BLAKE2B c2a1cb74a0c5d9ea7ea245b1c55413b8d212dc091bc7ad8727ca4cc4249cbc60e92c5313a5a1f8daf5dcea64485b27fbeeae9fada18727aed20dc38779d112ea SHA512 a6c174a52947f3985a0bbed20996e8386efdac6100a6c7ce9994bb6be7617bf810ac04821fae122e569e1883e8a8b1350cdccfa2b02053e5a4fbd13f891716e4
diff --git a/www-apache/passenger/passenger-6.0.5.ebuild b/www-apache/passenger/passenger-6.0.5.ebuild
new file mode 100644
index 000000000000..62621a5f00d0
--- /dev/null
+++ b/www-apache/passenger/passenger-6.0.5.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
+
+DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
+HOMEPAGE="https://www.phusionpassenger.com/"
+SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="apache2 debug"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+ruby_add_rdepend "
+ >=dev-ruby/rack-1.0.0:*
+ >=dev-ruby/rake-0.8.1"
+
+# libev is bundled but with adapations that do not seem to be accepted
+# upstream, so we must use the bundled version :-(
+CDEPEND="
+ >=dev-libs/libuv-1.8.0
+ net-misc/curl[ssl]
+ apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
+
+RDEPEND="${RDEPEND} ${CDEPEND}"
+DEPEND="${DEPEND} ${CDEPEND}"
+
+APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
+APACHE2_MOD_DEFINE="PASSENGER"
+
+want_apache2
+
+pkg_setup() {
+ use debug && append-flags -DPASSENGER_DEBUG
+ depend.apache_pkg_setup
+}
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
+ eapply "${FILESDIR}"/${PN}-5.1.1-isnan.patch
+
+ # Change these with sed instead of a patch so that we can easily use
+ # the toolchain-funcs methods.
+ sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
+ -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
+ -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
+
+ # Avoid fixed debugging CFLAGs.
+ sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
+
+ # Use sed here so that we can dynamically set the documentation directory.
+ sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
+ -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
+ src/ruby_supportlib/phusion_passenger.rb || die
+ sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
+
+ # Don't install a tool that won't work in our setup.
+ sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
+ rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
+
+ # Make sure we use the system-provided version where possible
+ rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
+
+ # Avoid building documentation to avoid a dependency on mizuho.
+ #sed -i -e 's/, :doc//' build/packaging.rb || die
+ touch doc/*.html || die
+
+ # Fix hard-coded use of AR
+ sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
+
+ # Make sure apache support is not attempted with -apache2
+ if ! use apache2 ; then
+ sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
+ fi
+}
+
+all_ruby_compile() {
+ if use apache2 ; then
+ V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ FS_LIBDIR='/usr/'$(get_libdir) \
+ USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+ RANLIB=$(tc-getRANLIB) \
+ ruby -S rake apache2 || die "rake failed"
+ fi
+}
+
+each_ruby_compile() {
+ append-flags -fno-strict-aliasing
+
+ V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ FS_LIBDIR='/usr/'$(get_libdir) \
+ USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+ RANLIB=$(tc-getRANLIB) \
+ ${RUBY} -S rake native_support || die "rake failed"
+}
+
+all_ruby_install() {
+ if use apache2 ; then
+ APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
+ apache-module_src_install
+
+ # Patch in the correct libdir
+ sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
+ fi
+
+ dodoc CHANGELOG README.md
+}
+
+each_ruby_install() {
+ DISTDIR="${D}" \
+ RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
+ RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ FS_LIBDIR='/usr/'$(get_libdir) \
+ EXTRA_LDFLAGS="${LDFLAGS}" \
+ USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+ RANLIB=$(tc-getRANLIB) \
+ ${RUBY} -S rake fakeroot || die "rake failed"
+}