summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.19.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 7e0bc5b8f108..b8d5b4b1826f 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,2 +1,3 @@
DIST pytest-httpx-0.17.3.tar.gz 23737 BLAKE2B 1f335542c1d6940d68b023682df6a1fabe93e8e21b70e113830bc4895481fe1cbf074490b176ecd91f595df960790f7e305c3809af3ba5039b96c8748b40ee40 SHA512 b3c2dc8c5015f44a511659b51843cb9cf8ada163ebd7fe4ccb50438d6e191fdc84bb84f38fcd0c27dbfe0592314da0df8d319caecad32f37e3a30de40b496299
DIST pytest-httpx-0.18.0.gh.tar.gz 22939 BLAKE2B a55923e63ad47ebd6ef05eafdadcec4caabab1341ab5f70e68357bc44cab53006a38b0d07f9540007ac46686499fd7355610a22a82b075a1e674d1fa3250efe9 SHA512 a7f24eefb8ba371e8c86526dd63e5ec7a6fa2e7a122643c8907a3da3b9a17a06e99416c5dc927f42320aa88fc213d5a327f53ec92e345853d5350902801fa1bc
+DIST pytest-httpx-0.19.0.gh.tar.gz 22971 BLAKE2B e62dbd043ff727d6b91d82963514d62f23766ad69380675334b6a429c11f00e2062cd0cc9dedce662c5ec13ff42f3eb9bb2620d0f021bfe9b5f4ad7ae7694d28 SHA512 a3a296445894cb8f68a8ce367b5e3e399471be45c6fa1d5fa4957910b45af244393957f49b5fb0ec2c0a0e8c507e63d572a0fa672430fe030b2529c2fefa6911
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.19.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.19.0.ebuild
new file mode 100644
index 000000000000..f33c4f734d50
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.19.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="https://colin-b.github.io/pytest_httpx/"
+SRC_URI="
+ https://github.com/Colin-b/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.22*[${PYTHON_USEDEP}]
+ =dev-python/pytest-6*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest