summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-process/htop/files/htop-2.2.0-gcc-10.patch27
-rw-r--r--sys-process/htop/htop-2.2.0.ebuild1
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-process/htop/files/htop-2.2.0-gcc-10.patch b/sys-process/htop/files/htop-2.2.0-gcc-10.patch
new file mode 100644
index 000000000000..dc49b0bb8508
--- /dev/null
+++ b/sys-process/htop/files/htop-2.2.0-gcc-10.patch
@@ -0,0 +1,27 @@
+--- a/CRT.h
++++ b/CRT.h
+@@ -140,7 +140,7 @@ extern const char **CRT_treeStr;
+
+ extern int CRT_delay;
+
+-int* CRT_colors;
++extern int* CRT_colors;
+
+ extern int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT];
+
+@@ -150,13 +150,13 @@ extern int CRT_scrollHAmount;
+
+ extern int CRT_scrollWheelVAmount;
+
+-char* CRT_termType;
++extern char* CRT_termType;
+
+ // TODO move color scheme to Settings, perhaps?
+
+ extern int CRT_colorScheme;
+
+-void *backtraceArray[128];
++extern void *backtraceArray[128];
+
+ #if HAVE_SETUID_ENABLED
+
diff --git a/sys-process/htop/htop-2.2.0.ebuild b/sys-process/htop/htop-2.2.0.ebuild
index 8e121bcacff1..318bdf97c5c0 100644
--- a/sys-process/htop/htop-2.2.0.ebuild
+++ b/sys-process/htop/htop-2.2.0.ebuild
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
DOCS=( ChangeLog README )
CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"