summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/dar/Manifest1
-rw-r--r--app-backup/dar/dar-2.6.2.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index f4b1001e373e..29a20b4900b6 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,3 +1,4 @@
DIST dar-2.5.11.tar.gz 1891928 BLAKE2B 536cccca2533f7ddbc8b95972fe00e9c87a404481e6afbd7aa3634c00598403c18950eb876aefe71a818c3bf4df75bff5f3904dc69bd1d75880f6c8a349911a5 SHA512 36b90218a34ac7f41ce9ca0a2167cfb2fd243b23b8e84350153e8804f0faabf87291b4e4b061533bcb0ca079f087c074eeaa12a54ee8084dd386a072ac503847
DIST dar-2.5.18.tar.gz 1931746 BLAKE2B 3d47665a1ab955ab9467d8f10a686565c549e1be57e77a9bcf65f1ea25c9b70d6d148d4b9dc35112b3ca74f9df05505c74e3a7eaa211b6a8b466308121206a2f SHA512 cde787bb4c3a3a1014efdb5e437b963d762eb87c512e1de1d60471035c535965e03adb5f75abc2bc95633bb6fb61226027d836a87fc903995e3a27a540632e69
DIST dar-2.6.1.tar.gz 2098547 BLAKE2B 6c1fe1670cf46faefe04544f3d7fce0dc819e24a493c6bc903465a11e4b25a9642faf68a0bb66a2c6a92bba2782f24c5694b14571ff2c205f7954941f14aca63 SHA512 492c9ce6d7928271e5b7f263773b2129c7a237ca192cd40698848d3bcf212224c76d29c3e33ff5a8642594697f5bba660f5e97d1c7529a5794e078f2de0716e9
+DIST dar-2.6.2.tar.gz 2100192 BLAKE2B 1eb2f92e5162070a75182741f850e79932593f68fd1f31a4a1d19af77c6f86df0c8e5b995b5ccd265f051891827bfa89bf71832cb7ce6f97d9ab70e768c867b4 SHA512 88f128f99a3fe22866056e2fc881276c13731004e40437f9e2c363c4e24f603ab5b9fe7126e4f950526ccfc1b6f86fe1a4494036e83e1faf9a647ce239293ea4
diff --git a/app-backup/dar/dar-2.6.2.ebuild b/app-backup/dar/dar-2.6.2.ebuild
new file mode 100644
index 000000000000..f84ffdbd95af
--- /dev/null
+++ b/app-backup/dar/dar-2.6.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="curl dar32 dar64 doc gcrypt gpg lzo nls static static-libs xattr"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND=">=sys-libs/zlib-1.2.3:=
+ !static? (
+ app-arch/bzip2:=
+ app-arch/xz-utils:=
+ sys-libs/libcap
+ curl? ( net-misc/curl )
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ gpg? ( app-crypt/gpgme )
+ lzo? ( dev-libs/lzo:= )
+ xattr? ( sys-apps/attr:= )
+ )"
+
+DEPEND="${RDEPEND}
+ static? (
+ app-arch/bzip2[static-libs]
+ app-arch/xz-utils[static-libs]
+ sys-libs/libcap[static-libs]
+ sys-libs/zlib[static-libs]
+ curl? ( net-misc/curl[static-libs] )
+ gcrypt? ( dev-libs/libgcrypt:0=[static-libs] )
+ gpg? (
+ app-crypt/gpgme[static-libs]
+ dev-libs/libassuan[static-libs]
+ dev-libs/libgpg-error[static-libs]
+ )
+ lzo? ( dev-libs/lzo[static-libs] )
+ xattr? ( sys-apps/attr[static-libs] )
+ )
+ nls? (
+ sys-devel/gettext
+ virtual/libintl
+ )
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="?? ( dar32 dar64 )
+ gpg? ( gcrypt )"
+
+#PATCHES=(
+#)
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-upx
+ $(usex curl '' --disable-libcurl-linking)
+ $(usex dar32 --enable-mode=32 '')
+ $(usex dar64 --enable-mode=64 '')
+ $(usex doc '' --disable-build-html)
+ #$(usex examples --enable-examples '')
+ $(usex gcrypt '' --disable-libgcrypt-linking)
+ $(usex gpg '' --disable-gpgme-linking)
+ $(usex lzo '' --disable-liblzo2-linking)
+ $(usex nls '' --disable-nls)
+ #$(usex rsync '' --disable-librsync-linking)
+ $(usex xattr '' --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ if ! use static ; then
+ myconf+=( --disable-dar-static )
+ if ! use static-libs ; then
+ myconf+=( --disable-static )
+ fi
+ fi
+
+ econf ${myconf[@]}
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ local DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+}