summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/slop/Manifest1
-rw-r--r--dev-ruby/slop/slop-4.7.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/slop/Manifest b/dev-ruby/slop/Manifest
index 052c826c9a37..7fe1ac7a76c2 100644
--- a/dev-ruby/slop/Manifest
+++ b/dev-ruby/slop/Manifest
@@ -1 +1,2 @@
DIST slop-4.6.2.tgz 15750 BLAKE2B a31c8ec895e534be7fe77eb09909c2210d298c1a89099080af816b9e06a5ee2358aef223b1ce0669f9d40cc91c04ce55e8ebb6d506a4bec35fb1fd9b93c0017d SHA512 352d7e5bbbe9ae4c324d1561f953fe28c1c99078bdef27f1be45453e60b34e0191e94d8952ec0a8cee7d689c6ba910616c9515747e81a8378fa825cb2139bfc7
+DIST slop-4.7.0.tgz 16367 BLAKE2B ad128b803876184cddaca5fdc4c8a1c2d20a0deab46cfcc9521cec88dbc777ee849a8bda8b0257281fdcb614a1e710e25b683f9a5f7d97d34ad78e3a1479a88f SHA512 3cbf1c7e2a7f2baf01e533b10f29cb52060dab2d03f69ba345b63cc0aa9d4cdebf1d18eff26177bfbac11bf55fd1167605dcc86d030fed0568fa132de33d1f37
diff --git a/dev-ruby/slop/slop-4.7.0.ebuild b/dev-ruby/slop/slop-4.7.0.ebuild
new file mode 100644
index 000000000000..9ca73f9366d6
--- /dev/null
+++ b/dev-ruby/slop/slop-4.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}