summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-sports/xmoto/Manifest1
-rw-r--r--games-sports/xmoto/metadata.xml1
-rw-r--r--games-sports/xmoto/xmoto-0.5.11-r2.ebuild92
3 files changed, 94 insertions, 0 deletions
diff --git a/games-sports/xmoto/Manifest b/games-sports/xmoto/Manifest
index 1bf0d5150451..479735b27932 100644
--- a/games-sports/xmoto/Manifest
+++ b/games-sports/xmoto/Manifest
@@ -1,3 +1,4 @@
DIST inksmoto-0.7.0.tar.gz 2628941 BLAKE2B b8469739e6368f7b36b9a5b766522c295de43c001fba00975fb3c761ba6df34bf97e684ddf51aa83a6a41a1b800d64d6d6fe77358cf1244f193d3aad4746c6b5 SHA512 af0ae49ea160a2274f6835abd82ccaa00dc9ff81875b7d4ea29789388c131b519cb77e6da42efeaf51d52b97090c67320af38145204a1d5418781c99cb23a704
DIST xmoto-0.5.11-src.tar.gz 40785573 BLAKE2B a1c19656ec5b206417ebdf5ac80e134ce7f29258d8a76f47bad4084ce4d2cdaeeecde1cf6cef1254a0832f21c50a49049947c1896681fe2dd8f3531ba22e7627 SHA512 7046745e8f7a045fa2ce1deb3fd75b73b233dc1092f5ecd6dd4e42938f70269a93a3a623a39a1f0520c90643a42dc1ce93c43ad07bf225ff6c50741cc02511f6
DIST xmoto_0.5.11+dfsg-6.debian.tar.xz 25240 BLAKE2B a1509cc25eca4f56e6bdad04aecf2cd63d9a2515b7dc7cebce64cde09de770636707a8344efda1e73d078185abdbaf0eaddeb1466081e4465e779f702866f8c2 SHA512 961f97a3427e77cf020d73820ff99fdc0ca81e5953a18ed9386a1b476eb2af897073adcd7141e993fbf4f8fdca9efdab8cf20b89bfc31196afdcb4f2095ab390
+DIST xmoto_0.5.11+dfsg-7.debian.tar.xz 25708 BLAKE2B e4029d9c66b176c6eebbf68c973cb726ef7b2522c6245ce626c7a61c13492f2e599c5a7deff4f2c853bc58d21afb4e53072a0ddc25a4e7bdb8b89b93fd44159a SHA512 d430fa37fdde90ac68e8ff4b7d2707ea5fc73fa8fab241f7a97b27e803a88321f0ea01b094a5f77ac7e43b2202113842b4f69a745e9212eead7ce4a0a5cd220c
diff --git a/games-sports/xmoto/metadata.xml b/games-sports/xmoto/metadata.xml
index 23c7b787914a..5b72e0102ede 100644
--- a/games-sports/xmoto/metadata.xml
+++ b/games-sports/xmoto/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Games Project</name>
</maintainer>
<use>
+ <flag name="double-precision">more precise calculations at the expense of speed</flag>
<flag name="editor">Depend on inkscape, scripts to convert svg to level (svg2lvl)</flag>
</use>
</pkgmetadata>
diff --git a/games-sports/xmoto/xmoto-0.5.11-r2.ebuild b/games-sports/xmoto/xmoto-0.5.11-r2.ebuild
new file mode 100644
index 000000000000..4a48f02abbc4
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.5.11-r2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils flag-o-matic
+
+LVL_PV="0.7.0" #they unfortunately don't release both at the same time, why ~ as separator :(
+LVL="inksmoto-${LVL_PV}"
+DEB_PV=7
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/xmoto/xmoto/${PV}/${P}-src.tar.gz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV}+dfsg-${DEB_PV}.debian.tar.xz
+ editor? ( http://download.tuxfamily.org/xmoto/svg2lvl/${LVL_PV}/${LVL}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="double-precision editor nls"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-db/sqlite:3
+ dev-games/ode[double-precision=]
+ dev-lang/lua:0[deprecated]
+ dev-libs/libxdg-basedir
+ dev-libs/libxml2
+ media-fonts/dejavu
+ media-libs/libpng:0
+ media-libs/libsdl[joystick,opengl]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ net-misc/curl
+ virtual/jpeg:0
+ virtual/opengl
+ virtual/glu
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ editor? ( media-gfx/inkscape )"
+
+src_prepare() {
+ default
+
+ EPATCH_SOURCE="${WORKDIR}/debian/patches" \
+ epatch $(cat ${WORKDIR}/debian/patches/series)
+ use editor && rm -vf "${WORKDIR}"/extensions/{bezmisc,inkex}.py
+ sed -i \
+ -e '/^gettextsrcdir/s:=.*:= @localedir@/gettext/po:' \
+ po/Makefile.in.in || die
+ mv configure.{in,ac} || die
+ eautoreconf
+
+ rm -r "${S}"/src/ode || die
+}
+
+src_configure() {
+ econf \
+ --enable-threads=posix \
+ $(use_enable nls) \
+ --localedir=/usr/share/locale \
+ --with-localesdir=/usr/share/locale \
+ --with-renderer-sdlGfx=0 \
+ --with-renderer-openGl=1
+}
+
+src_install() {
+ default
+
+ rm -f "${D}/usr/share/xmoto"/Textures/Fonts/DejaVu*.ttf
+ dosym ../../../fonts/dejavu/DejaVuSans.ttf /usr/share/xmoto/Textures/Fonts/DejaVuSans.ttf
+ dosym ../../../fonts/dejavu/DejaVuSansMono.ttf /usr/share/xmoto/Textures/Fonts/DejaVuSansMono.ttf
+ doicon extra/xmoto.xpm
+ make_desktop_entry xmoto Xmoto
+
+ if use editor; then
+ insinto /usr/share/inkscape/
+ doins -r "${WORKDIR}"/extensions/
+ fi
+}
+
+pkg_postinst() {
+ if use editor; then
+ elog "If you want to know how to create Xmoto levels"
+ elog "have a look at this Tutorial:"
+ elog " http://wiki.xmoto.tuxfamily.org/index.php?title=Inksmoto-${LVL_PV}"
+ elog "You can share your levels on the Xmoto homepage."
+ fi
+}