summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.0_rc8.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index ad57a007e973..5721e0ba15b7 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -6,3 +6,4 @@ DIST patch-5.0-rc4.patch 42678556 BLAKE2B 0b1610bb3bd444d70927ed64806ab3dd9e994d
DIST patch-5.0-rc5.patch 42841821 BLAKE2B f7e27c9e475480245484ca22bbcfdeaa258e3bd7f27d95c1e1508c8d910d4f36f8a984ebc45855ea660d828eebf678ba68358f6dec3b68dd3ded64dd2d1f2ba8 SHA512 04d05fe675d90644606d8c8d19bbf32d912c9ffd670b32abdb72f89492d04d5c4544910fe0f7695978ba6ae34bd41fedab0c7941d8c14cd32112ec6c142568ae
DIST patch-5.0-rc6.patch 43170751 BLAKE2B c88ec1b5be253a9cc6186720dac00d396ec17a22e0654c0d60308877a1a8f31669b674ad686b3f4c1895cf9a84b8cbd4c5f460dfe16c93f3323ac7a5d42c7780 SHA512 2d22e2a4bf8eb0eabc7401eaa741432c38314fd00133f9f04dc212e4c1e2b02a5ed9f42f1438d9b3ee429fb1bc18e14f7d18aa9b123dbaa382a4c249f88f9ed3
DIST patch-5.0-rc7.patch 43364873 BLAKE2B 8501ec5081cff19d8dad47f9b17e09f68601a58079e8077a304faa036b7577823616f1e6877b7f66fd16708493b972c6ddac4bde9c2c03864256cedb692223d3 SHA512 5429044dad3f17bfae70735ee6a3b062fa3848564979540e096432a6f3bd9459533c799843292b11884373513d0b15239f4fe2fe1f5e0802fddd357117858ecc
+DIST patch-5.0-rc8.patch 43587760 BLAKE2B a9f4e114712c35dfa8f75d72399ac25694768a399236862f2739c55abc078f1c1323aacb4b8a607a21f9caec7bfe50c48f918b950ddbaced5fcbfbafdeba8652 SHA512 4cc4437e1fdfed003df3caa8e2196b8c5e2c8f304b0127dcaef7e3f4a4cb1a688ae221c4949b32d4df82a5bd992a0037c9832f0cf1a5bc152e1c9eed4e83a7c3
diff --git a/sys-kernel/git-sources/git-sources-5.0_rc8.ebuild b/sys-kernel/git-sources/git-sources-5.0_rc8.ebuild
new file mode 100644
index 000000000000..10cee793e44d
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.0_rc8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.20"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}