summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/dropbox-cli/Manifest1
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-2022.ebuild31
-rw-r--r--net-misc/dropbox-cli/metadata.xml3
3 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/Manifest b/net-misc/dropbox-cli/Manifest
index bcb1d61f5c13..63a57f9688f6 100644
--- a/net-misc/dropbox-cli/Manifest
+++ b/net-misc/dropbox-cli/Manifest
@@ -1 +1,2 @@
DIST dropbox-cli-2020.03.04.py.xz 14304 BLAKE2B 600378cbacd6e96c16e1c8464261b260f2d8919ef5f361c4f337386d3849294cf8557d44f1c5d4f5682eadb2f15885a16b0a8fa162929665e518801d23ec35cc SHA512 c6c8f2f3fb08818388f5ac812821a1530214ad18d58191b08092852aa953e2947871145b46a4df4debeb629a870e1182a47fd5a8bdf8b22144e686e19ede689a
+DIST dropbox-cli-2022.py.xz 14288 BLAKE2B a90d347efcce5917179853afef346a6679dddbb33e146a936786c226ad519601f503d73eeb1d1e205be8bd11792aeedb90ff7046c770f079a47e75dea80efd99 SHA512 59bfbf3544a8407bbc232d87e57d8b27d4bbc108483af52e58c0badddde6ce2dfde2203403a8c5e8c95421fe8c4b73e75cec64def2699ae9bac31be965e98974
diff --git a/net-misc/dropbox-cli/dropbox-cli-2022.ebuild b/net-misc/dropbox-cli/dropbox-cli-2022.ebuild
new file mode 100644
index 000000000000..1b9b1364e01c
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-2022.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-r1 bash-completion-r1
+
+DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
+HOMEPAGE="https://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gpg"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}
+ gpg? ( app-crypt/gpgme[python] )
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+ newbashcomp "${FILESDIR}"/${PN}-19-completion ${PN}
+}
diff --git a/net-misc/dropbox-cli/metadata.xml b/net-misc/dropbox-cli/metadata.xml
index c5941bf7de12..1f35bc0d6b20 100644
--- a/net-misc/dropbox-cli/metadata.xml
+++ b/net-misc/dropbox-cli/metadata.xml
@@ -4,4 +4,7 @@
<maintainer type="person">
<email>grozin@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name="gpg">Use <pkg>app-crypt/gpgme</pkg> to verify signatures</flag>
+ </use>
</pkgmetadata>