summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/carrot_planner/Manifest1
-rw-r--r--dev-ros/carrot_planner/carrot_planner-1.15.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/carrot_planner/Manifest b/dev-ros/carrot_planner/Manifest
index 7214e3ac5d1e..1130f354eeda 100644
--- a/dev-ros/carrot_planner/Manifest
+++ b/dev-ros/carrot_planner/Manifest
@@ -1 +1,2 @@
DIST navigation-1.15.1.tar.gz 346480 BLAKE2B 29f9a0b6f2c62bd21a7cb87a64b490c845bb7db4af338fd094744abb22402df7eedc8c164b64f93f2d67dabaff99ca3b946b45e93173bed74834d9e3668726ad SHA512 25c5093bf7acca9d15d46bb2d0ae7e4ce0fa45f18b32d1626668dcbd33732317e8535b978e7225d86391472c517f05acb7736f31a7c511c8736ab8a22c7af4b0
+DIST navigation-1.15.2.tar.gz 348985 BLAKE2B 866779425828b1e4c3a044654ae41f33643646ca70cf6841f23bce265add2c420bf0934a41a6b29fa65fc421228a31dc15e9fb0f6cc4295ce12adbbb627b43d4 SHA512 582422756b31b4d83e929e3c723e7205e772b9775fcf618c9bd5d3c54af1f20e9bc8a0143626750c0c3cffeb0cbea8f8706b7e66f62dc037cfe12b05f23ee142
diff --git a/dev-ros/carrot_planner/carrot_planner-1.15.2.ebuild b/dev-ros/carrot_planner/carrot_planner-1.15.2.ebuild
new file mode 100644
index 000000000000..3f5f3f231f33
--- /dev/null
+++ b/dev-ros/carrot_planner/carrot_planner-1.15.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to find a legal place to put a carrot for the robot to follow"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/nav_core
+ dev-ros/costmap_2d
+ dev-ros/base_local_planner
+ dev-ros/pluginlib
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"