summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/burp/Manifest2
-rw-r--r--app-backup/burp/burp-2.1.10.ebuild112
-rw-r--r--app-backup/burp/burp-2.1.12.ebuild114
3 files changed, 0 insertions, 228 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index f04242a70fba..f823ce4343e8 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -1,5 +1,3 @@
DIST burp-1.4.40.tar.bz2 712937 SHA256 4108eb45e14740de990d918a2adbb661d88f90de48d6e2e3a6b54fd12b16fa5e SHA512 b44ba3a63d3b75f6fee55bbfef70ac07fa87e78ddb22a398e31a86670dfa3f2db1c9dbc58de3d0038cdc409bd5ae52c8e901cb26975fd7dbe0f773c4841af10c WHIRLPOOL 636120b3fa2d4a3217567177f3c8abbdeb562d298043fd6bd685842287964d835f2a369e36db0bc32ce908ce8f96e4e2677569e6ca4bac80f8d9958a2364a62d
DIST burp-2.0.54.tar.gz 558845 SHA256 26130da9791c57b1e194973ef1ea292dec57468bf4291a4d0eae880d192c1fd1 SHA512 dccc4d3679dd759028cd6b71d09ae4e49a511e5d94b4df2f112ad974abb507bbc8fffaf63ef85c847b0f9363b20a9e817179ab556c5a788acacb7a25e7600fa4 WHIRLPOOL 60e9bec56c08bc7ebc4700824eab34cf8cefdc5871140471eec5e05dbff4f4b83c2f7c6d5554d33dbb918f46e2c60159ba99a5da599938acd40b9d5b7b582978
-DIST burp-2.1.10.tar.gz 574716 SHA256 857492493fe8ba21c54dc77e36bdedd5009edb7be66e19c533c6c0d437927d99 SHA512 ebb9901c4f5b281f05fe96499067a3e85edb7dab3132a7e00b14f10a5bb2ce51ccb32ce466176ca9b2ffcba70c7bc168b258df2494bbc6e984391f1c3fd8803a WHIRLPOOL ffc01c898033cc112bf2a01bfc2b2871152f13cbeac4a8f8b96f4432476e75ccb170f36e8af7ecee7bce05601e87959803a8b1c96cfb7e717c7648d5399ff5e4
-DIST burp-2.1.12.tar.gz 576544 SHA256 78ebd3f9a37daf935f474b1e297f716172e44db45f6641966eca2b0fa3aafce1 SHA512 85715593178bc77640b246ed5d10278a16ff4151274391c88981366d284c5a4315c542912a0d590162418e7556450ebe523b97ff2f5123413d1ce01c5b140a45 WHIRLPOOL bed5f0fb92b42cd8de1425395dc7f774747061d7ef873eb2d59b2e31815c978c91eb9e25fd8ac7c5bdaa167377760f101fea24d16cb0c3c5ba569481b5e111fe
DIST burp-2.1.20.tar.gz 579488 SHA256 225f8ac0ad80ef4fa19c77c2d397d6829086a29dd8ab3d762820b9862d8b8f5c SHA512 5937187e0c93e21b4e3f4ab92f05589f8da56c774cf86644f095a0bff93c127911b2d513c04e380188956c2a97fb01ce471bb746d630baa5d30e6a70b53a0389 WHIRLPOOL b1253df69e20c9448249e14c898cdabc40ba5cbe5e5da5e20c8c4d7e161bf498b9f8a7ead80175d1bf00ad4b0bc893436abde27e37b61b1fad1792de04f16e99
diff --git a/app-backup/burp/burp-2.1.10.ebuild b/app-backup/burp/burp-2.1.10.ebuild
deleted file mode 100644
index 3b33781ac1ec..000000000000
--- a/app-backup/burp/burp-2.1.10.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools systemd tmpfiles user versionator
-
-DESCRIPTION="Network backup and restore client and server for Unix and Windows"
-HOMEPAGE="http://burp.grke.org/"
-SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="acl ipv6 libressl test xattr"
-
-CDEPEND="dev-libs/uthash
- net-libs/librsync
- sys-libs/ncurses:0=
- sys-libs/zlib
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )"
-DEPEND="${CDEPEND}
- test? ( dev-libs/check )"
-RDEPEND="${CDEPEND}
- virtual/logger"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.54-no_mkdir_run.patch
- "${FILESDIR}"/${PN}-2.0.54-protocol1_by_default.patch
- "${FILESDIR}"/${PN}-2.0.54-server_user.patch
-)
-
-pkg_setup() {
- enewgroup "${PN}"
- enewuser "${PN}" -1 "" "" "${PN}"
-}
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/var
- --sysconfdir=/etc/burp
- --enable-largefile
- $(use_enable acl)
- $(use_enable ipv6)
- $(use_enable xattr)
- )
- # --runstatedir option will only work from autoconf-2.70 onwards
- runstatedir='/run/burp' \
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- fowners -R root:${PN} /var/spool/burp
- fperms 0770 /var/spool/burp
-
- emake DESTDIR="${D}" install-configs
- fowners -R root:${PN} /etc/burp
- fperms 0775 /etc/burp
- fperms 0640 /etc/burp/burp-server.conf
- fperms 0750 /etc/burp/clientconfdir
-
- newinitd "${FILESDIR}"/${PN}2.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-
- newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
-
- elog "Burp ebuilds now support the autoupgrade mechanism in both"
- elog "client and server mode. In both cases it is disabled by"
- elog "default. You almost certainly do NOT want to enable it in"
- elog "client mode because upgrades obtained this way will not be"
- elog "managed by Portage."
-
- if [[ ! -e /etc/burp/CA/index.txt ]]; then
- elog ""
- elog "At first run burp server will generate DH parameters and SSL"
- elog "certificates. You should adjust configuration before."
- elog "Server configuration is located at"
- elog ""
- elog " /etc/burp/burp-server.conf"
- elog ""
- fi
-
- # According to PMS this can be a space-separated list of version
- # numbers, even though in practice it is typically just one.
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if [[ $(get_major_version ${oldver}) -lt 2 ]]; then
- ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
- ewarn "the server config file by default. If you use bedup, please"
- ewarn "update your scripts to invoke it as"
- ewarn ""
- ewarn " bedup -c /etc/burp/burp-server.conf"
- ewarn ""
- ewarn "Otherwise deduplication will not work!"
- break
- fi
- done
-}
diff --git a/app-backup/burp/burp-2.1.12.ebuild b/app-backup/burp/burp-2.1.12.ebuild
deleted file mode 100644
index e05b1d7a3ff6..000000000000
--- a/app-backup/burp/burp-2.1.12.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools systemd tmpfiles user versionator
-
-DESCRIPTION="Network backup and restore client and server for Unix and Windows"
-HOMEPAGE="http://burp.grke.org/"
-SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="acl ipv6 libressl test xattr"
-
-CDEPEND="dev-libs/uthash
- net-libs/librsync
- sys-libs/ncurses:0=
- sys-libs/zlib
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- test? ( dev-libs/check )"
-RDEPEND="${CDEPEND}
- virtual/logger"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.54-ncurses_pkg-config.patch
- "${FILESDIR}"/${PN}-2.0.54-no_mkdir_run.patch
- "${FILESDIR}"/${PN}-2.0.54-protocol1_by_default.patch
- "${FILESDIR}"/${PN}-2.0.54-server_user.patch
-)
-
-pkg_setup() {
- enewgroup "${PN}"
- enewuser "${PN}" -1 "" "" "${PN}"
-}
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/var
- --sysconfdir=/etc/burp
- --enable-largefile
- $(use_enable acl)
- $(use_enable ipv6)
- $(use_enable xattr)
- )
- # --runstatedir option will only work from autoconf-2.70 onwards
- runstatedir='/run/burp' \
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- fowners -R root:${PN} /var/spool/burp
- fperms 0770 /var/spool/burp
-
- emake DESTDIR="${D}" install-configs
- fowners -R root:${PN} /etc/burp
- fperms 0775 /etc/burp
- fperms 0640 /etc/burp/burp-server.conf
- fperms 0750 /etc/burp/clientconfdir
-
- newinitd "${FILESDIR}"/${PN}2.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-
- newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
-
- elog "Burp ebuilds now support the autoupgrade mechanism in both"
- elog "client and server mode. In both cases it is disabled by"
- elog "default. You almost certainly do NOT want to enable it in"
- elog "client mode because upgrades obtained this way will not be"
- elog "managed by Portage."
-
- if [[ ! -e /etc/burp/CA/index.txt ]]; then
- elog ""
- elog "At first run burp server will generate DH parameters and SSL"
- elog "certificates. You should adjust configuration before."
- elog "Server configuration is located at"
- elog ""
- elog " /etc/burp/burp-server.conf"
- elog ""
- fi
-
- # According to PMS this can be a space-separated list of version
- # numbers, even though in practice it is typically just one.
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if [[ $(get_major_version ${oldver}) -lt 2 ]]; then
- ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
- ewarn "the server config file by default. If you use bedup, please"
- ewarn "update your scripts to invoke it as"
- ewarn ""
- ewarn " bedup -c /etc/burp/burp-server.conf"
- ewarn ""
- ewarn "Otherwise deduplication will not work!"
- break
- fi
- done
-}