summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/vim-nftables/Manifest1
-rw-r--r--app-vim/vim-nftables/vim-nftables-0.9_p20200613.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/vim-nftables/Manifest b/app-vim/vim-nftables/Manifest
index 376e4ff01607..91a5999d73db 100644
--- a/app-vim/vim-nftables/Manifest
+++ b/app-vim/vim-nftables/Manifest
@@ -1 +1,2 @@
+DIST vim-nftables-0.9_p20200613.tar.gz 3029968 BLAKE2B 00696b95ec7de7c574159cf5f9d27e27c833af4cd7869551c3684285d6f38490cb2b98cfe1a638e3d42a30b06933e5fb8f4b54dbd2dd4649380d2b4102ad1c71 SHA512 cb63f8b2f9f52ca09448ab4572e65f1514aeda78d256814eee266d5973a18cca075cc232dd736b0503e950fea2c5e26990e3f60528559e1ac1b51c54c36014df
DIST vim-nftables-0_pre20200224.tar.gz 2427 BLAKE2B a17780ffcabd1d323f3ccaa52e9726c2d8dc04583003fd8eaa799c897d1ccb1718a2ef28c2c06f0108785bdcc90addfb27d54f73db8d9f59b225e34c244cf179 SHA512 05dab5d9bdaed4ae1de9e00f2d6996f4350d859af73062d00417ee6567041c0a3fa6f50996fefa64e7a2410779b254ddeac1d5a893aa2f664504278b67fa2fd9
diff --git a/app-vim/vim-nftables/vim-nftables-0.9_p20200613.ebuild b/app-vim/vim-nftables/vim-nftables-0.9_p20200613.ebuild
new file mode 100644
index 000000000000..b3eba7c2e8d4
--- /dev/null
+++ b/app-vim/vim-nftables/vim-nftables-0.9_p20200613.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+COMMIT_ID="ec09292c0d7762c8675f9b08f473af8bd9803afc"
+
+DESCRIPTION="vim plugin: "
+HOMEPAGE="https://github.com/egberts/vim-nftables"
+SRC_URI="https://github.com/egberts/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ # will install license file by default
+ rm LICENSE || die
+}