summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild b/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
index 9a0508821fb2..cbd327fef5f6 100644
--- a/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
+++ b/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
-
-inherit eutils
+EAPI=7
DESCRIPTION="A fulltext search engine for Tokyo Cabinet"
HOMEPAGE="http://fallabs.com/tokyodystopia/"
@@ -17,28 +15,27 @@ IUSE="examples"
DEPEND="dev-db/tokyocabinet"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}/fix_rpath.patch"
- epatch "${FILESDIR}/fix_ldconfig.patch"
- epatch "${FILESDIR}/remove_docinst.patch"
-}
+PATCHES=(
+ "${FILESDIR}/fix_rpath.patch"
+ "${FILESDIR}/fix_ldconfig.patch"
+ "${FILESDIR}/remove_docinst.patch"
+)
src_configure() {
- econf --libexecdir=/usr/libexec/${PN} || die
+ econf --libexecdir="${EPREFIX}"/usr/libexec/${PN}
}
src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
+ HTML_DOCS=( doc/* )
- dohtml doc/* || die
+ default
if use examples; then
insinto /usr/share/${PF}/example
- doins example/* || die "Install failed"
+ doins example/*
fi
-
}
src_test() {
- emake -j1 check || die "Tests failed"
+ emake -j1 check
}