summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-nntp/nzbget/Manifest1
-rw-r--r--net-nntp/nzbget/nzbget-21.0_pre2220.ebuild129
2 files changed, 0 insertions, 130 deletions
diff --git a/net-nntp/nzbget/Manifest b/net-nntp/nzbget/Manifest
index 11e82283de49..6ce746854ace 100644
--- a/net-nntp/nzbget/Manifest
+++ b/net-nntp/nzbget/Manifest
@@ -1,4 +1,3 @@
DIST nzbget-20.0.tar.gz 1925665 BLAKE2B 4c4e93bb0fa170b4b6433cbb7d27f3fa67ed033c462711b19e179f42c18dfed044c937e6a7ce4b08a620f4d7af7d3ec9245de16f15d4db8005d3d8dc4f8f46d4 SHA512 8b0fe8ea41b64be9a2f624ef0fa2a8b8987bee412db68a0e8f1b607ce6be7bfd03f60ecc5e49807f4c726e136bc5a355c44559b215fea2bd290c2eb62a0b5927
DIST nzbget-21.0.tar.gz 1988902 BLAKE2B ee9204a978502562348dc4945e19b084d8d17f566099cfe7e95dac154ffac6d772084c9c070fba0d585cd2229d0a5760b3298ef29eba52d7c75edbc9fe43e310 SHA512 bbee5073a2788a17d78009b7ae0c41473aa4d8424301e7e62b2544dc8993e1e3b6e1026dd9f71af5627293d2113d8637a4a6138eee0a328554df298117dd6bb3
-DIST nzbget-21.0_pre2220.tar.gz 1985190 BLAKE2B e19e1c997615f61895a26ca24ff1eb66e6caf99cecf3f3b0eccc2c0f67ebc61c20cdd24d869d8c2a1d2f0d5c53f5222cc3b151720e3a6d1398507fd252586cf5 SHA512 73cd24628ab224d62b4619ca6b9014edb08ac14f02850def3123db640c785fd8836ba4ee4be40a0cf918ba6c25bf19683e67d05aaa0f96c71ad23b6a30284fa0
DIST nzbget-21.0_pre2302.tar.gz 1989357 BLAKE2B bf937b48c8f26e1144d4b09467a29b96984b9d0a777f6e6728a1922b7718dd2f2847ba51a9baf4cca0cebb7add60807f0f285e5dbeca871d99f0cd279fb292a3 SHA512 672f15df910e79ff39090f812a5925d15efb46c9538b7ca193266a159c95e7487fb31ef4780370532bbc9de8478cd927c461dee1f46cd0bf1d294420f796001e
diff --git a/net-nntp/nzbget/nzbget-21.0_pre2220.ebuild b/net-nntp/nzbget/nzbget-21.0_pre2220.ebuild
deleted file mode 100644
index 59e359e545b3..000000000000
--- a/net-nntp/nzbget/nzbget-21.0_pre2220.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools eutils flag-o-matic user systemd
-
-MY_PV=${PV/_pre/-r}
-MY_P=${PN}-${PV/_pre/-testing-r}
-
-DESCRIPTION="A command-line based binary newsgrabber supporting .nzb files"
-HOMEPAGE="https://nzbget.net/"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}-src.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="debug gnutls ncurses +parcheck ssl test zlib"
-
-RDEPEND="dev-libs/libxml2:=
- ncurses? ( sys-libs/ncurses:0= )
- ssl? (
- gnutls? (
- net-libs/gnutls:=
- dev-libs/nettle:=
- )
- !gnutls? ( dev-libs/openssl:0=[-bindist] )
- )
- zlib? ( sys-libs/zlib:= )"
-DEPEND="${RDEPEND}
- test? (
- || (
- =app-arch/rar-5*
- =app-arch/unrar-5*
- )
- )
- virtual/pkgconfig"
-DOCS=( ChangeLog README nzbget.conf )
-
-S=${WORKDIR}/${PN}-${PV/_pre*/-testing}
-
-check_compiler() {
- if [[ ${MERGE_TYPE} != binary ]] && ! test-flag-CXX -std=c++14; then
- eerror "${P} requires a C++14-capable compiler. Your current compiler"
- eerror "does not seem to support the -std=c++14 option. Please"
- eerror "upgrade to gcc-4.9 or an equivalent version supporting C++14."
- die "The currently active compiler does not support -std=c++14"
- fi
-}
-
-pkg_pretend() {
- check_compiler
-}
-
-pkg_setup() {
- check_compiler
-}
-
-src_prepare() {
- default
- eautoreconf
-
- sed -i 's:^ScriptDir=.*:ScriptDir=/usr/share/nzbget/ppscripts:' nzbget.conf || die
-
- sed \
- -e 's:^MainDir=.*:MainDir=/var/lib/nzbget:' \
- -e 's:^LogFile=.*:LogFile=/var/log/nzbget/nzbget.log:' \
- -e 's:^WebDir=.*:WebDir=/usr/share/nzbget/webui:' \
- -e 's:^ConfigTemplate=.*:ConfigTemplate=/usr/share/nzbget/nzbget.conf:' \
- -e 's:^DaemonUsername=.*:DaemonUsername=nzbget:' \
- nzbget.conf > nzbgetd.conf || die
-}
-
-src_configure() {
- local myconf=(
- $(use_enable debug)
- $(use_enable ncurses curses)
- $(use_enable parcheck)
- $(use_enable ssl tls)
- $(use_enable zlib gzip)
- $(use_enable test tests)
- --with-tlslib=$(usex gnutls GnuTLS OpenSSL)
- )
- econf "${myconf[@]}"
-}
-
-src_test() {
- ./nzbget --tests || die "Tests failed"
-}
-
-src_install() {
- default
-
- insinto /etc
- doins nzbget.conf
- doins nzbgetd.conf
-
- keepdir /var/lib/nzbget/{dst,nzb,queue,tmp}
- keepdir /var/log/nzbget
-
- newinitd "${FILESDIR}"/nzbget.initd-r1 nzbget
- newconfd "${FILESDIR}"/nzbget.confd nzbget
- systemd_dounit "${FILESDIR}"/nzbget.service
-}
-
-pkg_preinst() {
- enewgroup nzbget
- enewuser nzbget -1 -1 /var/lib/nzbget nzbget
-
- fowners nzbget:nzbget /var/lib/nzbget/{dst,nzb,queue,tmp}
- fperms 750 /var/lib/nzbget/{queue,tmp}
- fperms 770 /var/lib/nzbget/{dst,nzb}
-
- fowners nzbget:nzbget /var/log/nzbget
- fperms 750 /var/log/nzbget
-
- fowners nzbget:nzbget /etc/nzbgetd.conf
- fperms 640 /etc/nzbgetd.conf
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog
- elog "Please add users that you want to be able to use the system-wide"
- elog "nzbget daemon to the nzbget group. To access the daemon, run nzbget"
- elog "with the --configfile /etc/nzbgetd.conf option."
- elog
- fi
-}