summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/packaging/Manifest1
-rw-r--r--dev-python/packaging/packaging-20.7.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index 9fdbdf6a4744..b5a068ee510b 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,2 +1,3 @@
DIST packaging-20.4.tar.gz 74402 BLAKE2B 3c667c1605445aec37d264ec3846a1a6678f13a12aecc09a6d16e09ea27041fcd65d23538acef4f6272ab0458ce479c42906b15cb6eddd9c8001b1970c23e4fc SHA512 d53912041a9950efb5d221fc968adc328c2ef1e54ec9806d2158fd6db1b170e37afb05213f5750b10c59927504083ca3781c958caa0c802b1c7c0fe1ac1682a4
DIST packaging-20.5.gh.tar.gz 75111 BLAKE2B b088b85fc042b48337878c0f663934f32f90eb792ba53257b1b0879a097ef042b67a9cff56b23f5e0187a3df0f89092e0210939382851f0ae917f6ef00ad73ff SHA512 ef3c4853c30d9635b9372d6861cc0df8f7fc5a1d784e5f3effe3f315da0f24662ac939e70f55c6e9bb8864da95b9f75bc0df093f12c0f5c2af654b5354a5f081
+DIST packaging-20.7.gh.tar.gz 75182 BLAKE2B f3ba27ec33db576273609f28aabb5edab4acd07d8174c96e3a1608eacdc1a571d2ce96cc4e38c50c964ae5a716bbca077effd6dea039b25ac7bd6ce5707ae08b SHA512 4da8f66af066ac92b47664d21af34a02526cd1639cb766927670bec0ac8c7416116834c847678a29862a46faeda7e2f2393744be315cdfbbb8bd55a04ceb942c
diff --git a/dev-python/packaging/packaging-20.7.ebuild b/dev-python/packaging/packaging-20.7.ebuild
new file mode 100644
index 000000000000..6d1b30fa1a72
--- /dev/null
+++ b/dev-python/packaging/packaging-20.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/"
+SRC_URI="
+ https://github.com/pypa/packaging/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ pytest --capture=no --strict -vv || die
+}