summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/yappi/Manifest1
-rw-r--r--dev-python/yappi/files/yappi-1.3.0-tests.patch12
-rw-r--r--dev-python/yappi/yappi-1.3.0.ebuild35
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/yappi/Manifest b/dev-python/yappi/Manifest
index 8a01e41fcc03..bd655310b9cc 100644
--- a/dev-python/yappi/Manifest
+++ b/dev-python/yappi/Manifest
@@ -1 +1,2 @@
DIST yappi-1.2.5.tar.gz 928100 BLAKE2B 1d303226821d53fb215ac29f8363d9f564f9f40096b5ba8f67475c4074012316f523afb6d770cff879038cd333ef7f050b29c015e2dd2e517859f66a0e1f36f3 SHA512 ec784e76b56e8bc0c3cfe07c90d0810fa90d5a7da62f36187e8a09a9d6e01f3c2d74320de3dd3f4bf1d4a9425fee319c7a575a9d35ad5412c1501c934f1ba353
+DIST yappi-1.3.0.tar.gz 928100 BLAKE2B 1d303226821d53fb215ac29f8363d9f564f9f40096b5ba8f67475c4074012316f523afb6d770cff879038cd333ef7f050b29c015e2dd2e517859f66a0e1f36f3 SHA512 ec784e76b56e8bc0c3cfe07c90d0810fa90d5a7da62f36187e8a09a9d6e01f3c2d74320de3dd3f4bf1d4a9425fee319c7a575a9d35ad5412c1501c934f1ba353
diff --git a/dev-python/yappi/files/yappi-1.3.0-tests.patch b/dev-python/yappi/files/yappi-1.3.0-tests.patch
new file mode 100644
index 000000000000..866db78fac10
--- /dev/null
+++ b/dev-python/yappi/files/yappi-1.3.0-tests.patch
@@ -0,0 +1,12 @@
+diff -ur a/tests/test_functionality.py b/tests/test_functionality.py
+--- a/tests/test_functionality.py 2020-04-27 12:57:09.000000000 -0700
++++ b/tests/test_functionality.py 2020-10-30 18:08:35.619553108 -0700
+@@ -338,7 +338,7 @@
+ fsa = utils.find_stat_by_name(stats, "a")
+ self.assertEqual(fsa.module, os.path.basename(fsa.module))
+
+- @unittest.skipIf(os.name == "nt", "do not run on Windows")
++ @unittest.skip("does not like ebuild environment")
+ def test_run_as_script(self):
+ import re
+ p = subprocess.Popen(
diff --git a/dev-python/yappi/yappi-1.3.0.ebuild b/dev-python/yappi/yappi-1.3.0.ebuild
new file mode 100644
index 000000000000..6b63a3df849c
--- /dev/null
+++ b/dev-python/yappi/yappi-1.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{7..9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+# no tags on github, no tests on pypi
+COMMIT_HASH="b6c7d9f0bb40b511f61bb82cc395ad9140a4f4b0"
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="https://pypi.org/project/yappi/ https://github.com/sumerc/yappi"
+SRC_URI="https://github.com/sumerc/yappi/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+#RDEPEND="
+# $(python_gen_cond_dep 'dev-python/contextvars[${PYTHON_USEDEP}]' 'python3_6')
+#"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}/yappi-1.2.5-warnings.patch"
+ "${FILESDIR}/yappi-1.3.0-tests.patch"
+)
+
+python_prepare_all() {
+ cp tests/utils.py "${S}" || die
+ distutils-r1_python_prepare_all
+}