summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild18
1 files changed, 3 insertions, 15 deletions
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild
index e68a0aea45c5..7180a2837a42 100644
--- a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.5.ebuild
@@ -1,35 +1,23 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python2_7 )
-inherit python-single-r1 xorg-2
+inherit xorg-2
DESCRIPTION="QEMU QXL paravirt video driver"
KEYWORDS="amd64 x86"
-IUSE="xspice"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
- xspice? (
- app-emulation/spice
- ${PYTHON_DEPS}
- )
x11-base/xorg-server[-minimal]
>=x11-libs/libdrm-2.4.46"
DEPEND="${RDEPEND}
>=app-emulation/spice-protocol-0.12.0
x11-base/xorg-proto"
-src_prepare() {
- python_fix_shebang scripts
- xorg-2_src_prepare
-}
-
src_configure() {
XORG_CONFIGURE_OPTIONS=(
- $(use_enable xspice)
+ --disable-xspice
)
xorg-2_src_configure
}