summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/osprofiler/Manifest1
-rw-r--r--dev-python/osprofiler/osprofiler-1.2.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/osprofiler/Manifest b/dev-python/osprofiler/Manifest
index 941889a4159c..ed1a4e819bf0 100644
--- a/dev-python/osprofiler/Manifest
+++ b/dev-python/osprofiler/Manifest
@@ -1 +1,2 @@
DIST osprofiler-0.3.0.tar.gz 42443 SHA256 7d7e1d0b93ce96901f7a307a712196273818a8f20e59916ff099589b48f53207 SHA512 a25c076f090b6e931efde487b8b000695be7077ca235e860997499dc3a67699cbf7ead9299f1aba77bcb9c402e7fc3dabc1005f349d349b9400b70c995001851 WHIRLPOOL cdc192ba11974de635f1e21da93cb1b5123c168c604fabf73471921618bc04f337d7173e8f9a5be4fdfc360ddf2f902b8e118af04804c4d9768745ef9a27d813
+DIST osprofiler-1.2.0.tar.gz 53375 SHA256 62447e1ed954587036e1fa62b9f7d5f9d23b585f6fd0bf7a4c3b7926880f7f0d SHA512 4c7d9ac8ed447e5b6bf8dabd37a144dad21c176e42abd20348a6f3fe2eccc9f05fa88aa04e63ea730bc9acd52c69a2949b39535363ba47e5b6ad96804fb3c0c5 WHIRLPOOL bee27edabea3ab48b742a0e220f26dc8d4595dc244ed676e402af81096daf533a2fea42ca89a3963d2d8d4eb5dba2e9e23edb8caca2b1c0eccb39956c7a82a8d
diff --git a/dev-python/osprofiler/osprofiler-1.2.0.ebuild b/dev-python/osprofiler/osprofiler-1.2.0.ebuild
new file mode 100644
index 000000000000..5c1c29e0d4a2
--- /dev/null
+++ b/dev-python/osprofiler/osprofiler-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Profiler Library"
+HOMEPAGE="https://launchpad.net/osprofiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-1.6.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+"