summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20210506.ebuild2
-rw-r--r--games-emulation/dolphin/files/dolphin-5.0_p20210506-musl.patch24
2 files changed, 26 insertions, 0 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild b/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild
index 2a9debffb0ff..fd44c78fa9e2 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild
@@ -71,6 +71,8 @@ BDEPEND="
RDEPEND="${RDEPEND}
vulkan? ( media-libs/vulkan-loader )"
+PATCHES=("${FILESDIR}"/${P}-musl.patch)
+
src_prepare() {
cmake_src_prepare
diff --git a/games-emulation/dolphin/files/dolphin-5.0_p20210506-musl.patch b/games-emulation/dolphin/files/dolphin-5.0_p20210506-musl.patch
new file mode 100644
index 000000000000..51570151c112
--- /dev/null
+++ b/games-emulation/dolphin/files/dolphin-5.0_p20210506-musl.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/799281
+https://github.com/dolphin-emu/dolphin/commit/7a1922fd8f0f6686188d179732c9757faf2d1b4f.patch
+
+From 7a1922fd8f0f6686188d179732c9757faf2d1b4f Mon Sep 17 00:00:00 2001
+From: thyrc <thyrc@users.noreply.github.com>
+Date: Mon, 14 Jun 2021 10:18:34 +0200
+Subject: [PATCH] Fix includes for musl libc
+
+---
+ Source/Core/Core/MemoryWatcher.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Source/Core/Core/MemoryWatcher.cpp b/Source/Core/Core/MemoryWatcher.cpp
+index 491ecd83150a..13843e2021ca 100644
+--- a/Source/Core/Core/MemoryWatcher.cpp
++++ b/Source/Core/Core/MemoryWatcher.cpp
+@@ -2,6 +2,7 @@
+ // Licensed under GPLv2+
+ // Refer to the license.txt file included.
+
++#include <cstring>
+ #include <fstream>
+ #include <iostream>
+ #include <sstream>