summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/puppet_forge/Manifest1
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-2.3.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/puppet_forge/Manifest b/dev-ruby/puppet_forge/Manifest
index 583e1a86edca..bf3e113a4622 100644
--- a/dev-ruby/puppet_forge/Manifest
+++ b/dev-ruby/puppet_forge/Manifest
@@ -1 +1,2 @@
DIST puppet_forge-2.2.9.gem 772608 BLAKE2B 15cad2cc183688262b96a35af46324a3264b8a615fa414bddb6b55587ac30f4fdcc64ddaa0f18b66571bde1a1eb17339bf1fad1630f3a06b6c1575cdbf1c9140 SHA512 753ad4b95db25c1ad284ceb802b03db9724f2a1c1f4522f252428f8ae7c6771361b6a38d070c2ce989bec9538471529cdd92c925501a0f8f4f1bb5e6d8ef3733
+DIST puppet_forge-2.3.0.gem 773632 BLAKE2B 6024eed4c7b62c19c04d4f45a03dd40fa14bf074a1c44c14c766527bc3f4937bd9ac553df14b432834fd3bafa8f680d8b677ccfe6b366b954336888cb9f25aff SHA512 7b14b006562874524c7a5045ae44fc7c3ac932aa32beb3751a6c18e3498401dc22294a81386d2ee25d5f8618efaa425b51798daec6f12193916c76dd28aafe85
diff --git a/dev-ruby/puppet_forge/puppet_forge-2.3.0.ebuild b/dev-ruby/puppet_forge/puppet_forge-2.3.0.ebuild
new file mode 100644
index 000000000000..b506f5ec6bf9
--- /dev/null
+++ b/dev-ruby/puppet_forge/puppet_forge-2.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL=locales
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
+HOMEPAGE="https://github.com/puppetlabs/forge-ruby"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/faraday-0.9.0:0
+ >=dev-ruby/faraday_middleware-0.9.0:0
+ >=dev-ruby/gettext-setup-0.11:0
+ dev-ruby/minitar
+ =dev-ruby/semantic_puppet-1*
+"
+
+all_ruby_prepare() {
+ # Avoid integration and user specs since they all require network access
+ rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
+
+ # Fix overly restrictive dependencies
+ sed -i \
+ -e '/faraday/ s/0.14.0/0.99.0/' \
+ -e '/faraday_middleware/ s/0.13.0/0.99.0/' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}