summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/apr-util/Manifest1
-rw-r--r--dev-libs/apr-util/apr-util-1.5.4-r3.ebuild139
-rw-r--r--dev-libs/apr-util/apr-util-1.5.4.ebuild112
3 files changed, 0 insertions, 252 deletions
diff --git a/dev-libs/apr-util/Manifest b/dev-libs/apr-util/Manifest
index 268dd4fa4146..3759f954dca7 100644
--- a/dev-libs/apr-util/Manifest
+++ b/dev-libs/apr-util/Manifest
@@ -1,2 +1 @@
-DIST apr-util-1.5.4.tar.bz2 694427 BLAKE2B 6de337fa48f0ca3775ba5b054b3a59726e25a35c9b2ea67323edde52c88e4affc0ea0a25a0a64f42c82f0927482d22dc6049286df8cb6048f8bbb61659beb0ac SHA512 ca877d8e444218c4ba0f28063ee075ddcd6c0a487b692dc80ef442fe775ec4eeb337c6957853772e8082e27edcb450d7e909c2c6c3ab4a95bbf0a5ee5ea4a2d1
DIST apr-util-1.6.1.tar.bz2 428595 BLAKE2B ab6eaf1594aaa1c7aae151319b630b83bdb8b68ec04f0e2b429b7c7789bdf274873270200ba43701359e2502d2be8624d8e42a56a5f399ec95a841e7c73ce706 SHA512 40eff8a37c0634f7fdddd6ca5e596b38de15fd10767a34c30bbe49c632816e8f3e1e230678034f578dd5816a94f246fb5dfdf48d644829af13bf28de3225205d
diff --git a/dev-libs/apr-util/apr-util-1.5.4-r3.ebuild b/dev-libs/apr-util/apr-util-1.5.4-r3.ebuild
deleted file mode 100644
index 05a79fc756d3..000000000000
--- a/dev-libs/apr-util/apr-util-1.5.4-r3.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
-# APR_PV="${PV}"
-APR_PV="1.5.2"
-
-inherit autotools db-use eutils libtool multilib toolchain-funcs
-
-DESCRIPTION="Apache Portable Runtime Utility Library"
-HOMEPAGE="http://apr.apache.org/"
-SRC_URI="mirror://apache/apr/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="1"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="berkdb doc freetds gdbm ldap libressl mysql nss odbc openssl postgres sqlite static-libs"
-#RESTRICT="test"
-
-RDEPEND="
- dev-libs/expat
- >=dev-libs/apr-${APR_PV}:1
- berkdb? ( >=sys-libs/db-4:= )
- freetds? ( dev-db/freetds )
- gdbm? ( sys-libs/gdbm:= )
- ldap? ( =net-nds/openldap-2* )
- mysql? ( =virtual/mysql-5* )
- nss? ( dev-libs/nss )
- odbc? ( dev-db/unixODBC )
- openssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl )
- )
- postgres? ( dev-db/postgresql:= )
- sqlite? ( dev-db/sqlite:3 )
-"
-DEPEND="
- ${RDEPEND}
- >=sys-devel/libtool-2.4.2
- doc? ( app-doc/doxygen )
-"
-
-DOCS=(CHANGES NOTICE README)
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.3-sysroot.patch #385775
-)
-
-src_prepare() {
- default
-
- # Fix usage of libmysqlclient (bug #620230)
- grep -lrF "libmysqlclient_r" "${S}" \
- | xargs sed 's@libmysqlclient_r@libmysqlclient@g' -i \
- || die
-
- mv configure.{in,ac} || die
- eautoreconf
- elibtoolize
-}
-
-src_configure() {
- local myconf=()
-
- tc-is-static-only && myconf+=( --disable-util-dso )
-
- if use berkdb; then
- local db_version
- db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
- db_version="$(db_ver_to_slot "${db_version}")"
- db_version="${db_version/\./}"
- myconf+=(
- --with-dbm=db${db_version}
- # We use $T for the libdir because otherwise it'd simply be the normal
- # system libdir. That's pointless as the compiler will search it for
- # us already. This makes cross-compiling and such easier.
- --with-berkeley-db="${SYSROOT}$(db_includedir 2>/dev/null):${T}"
- )
- else
- myconf+=( --without-berkeley-db )
- fi
-
- if use nss || use openssl ; then
- myconf+=( --with-crypto ) # 518708
- fi
-
- local myeconfargs=(
- --datadir="${EPREFIX}"/usr/share/apr-util-1
- --with-apr="${SYSROOT}${EPREFIX}"/usr
- --with-expat="${EPREFIX}"/usr
- --without-sqlite2
- $(use_with freetds)
- $(use_with gdbm)
- $(use_with ldap)
- $(use_with mysql)
- $(use_with nss)
- $(use_with odbc)
- $(use_with openssl)
- $(use_with postgres pgsql)
- $(use_with sqlite sqlite3)
- "${myconf[@]}"
- )
- econf "${myeconfargs[@]}"
- # Use the current env build settings rather than whatever apr was built with.
- sed -i -r \
- -e "/^(apr_builddir|apr_builders|top_builddir)=/s:=:=${SYSROOT}:" \
- -e "/^CC=/s:=.*:=$(tc-getCC):" \
- -e '/^(C|CPP|CXX|LD)FLAGS=/d' \
- -e '/^LTFLAGS/s:--silent::' \
- build/rules.mk || die
-}
-
-src_compile() {
- emake
- use doc && emake dox
-}
-
-src_install() {
- default
-
- find "${ED}" -name "*.la" -delete || die
- if [[ -d "${ED}usr/$(get_libdir)/apr-util-${SLOT}" ]] ; then
- find "${ED}usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -delete || die
- fi
- if ! use static-libs ; then
- find "${ED}" -name "*.a" -not -name "*$(get_libname)" -delete || die
- fi
-
- if use doc ; then
- docinto html
- dodoc -r docs/dox/html/*
- fi
-
- # This file is only used on AIX systems, which Gentoo is not,
- # and causes collisions between the SLOTs, so remove it.
- rm "${ED}usr/$(get_libdir)/aprutil.exp" || die
-}
diff --git a/dev-libs/apr-util/apr-util-1.5.4.ebuild b/dev-libs/apr-util/apr-util-1.5.4.ebuild
deleted file mode 100644
index ce02048009f1..000000000000
--- a/dev-libs/apr-util/apr-util-1.5.4.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
-# APR_PV="${PV}"
-APR_PV="1.4.6"
-
-inherit autotools db-use eutils libtool multilib toolchain-funcs
-
-DESCRIPTION="Apache Portable Runtime Utility Library"
-HOMEPAGE="http://apr.apache.org/"
-SRC_URI="mirror://apache/apr/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="1"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="berkdb doc freetds gdbm ldap mysql nss odbc openssl postgres sqlite static-libs"
-#RESTRICT="test"
-
-RDEPEND="dev-libs/expat
- >=dev-libs/apr-${APR_PV}:1
- berkdb? ( >=sys-libs/db-4 )
- freetds? ( dev-db/freetds )
- gdbm? ( sys-libs/gdbm )
- ldap? ( =net-nds/openldap-2* )
- mysql? ( =virtual/mysql-5* )
- nss? ( dev-libs/nss )
- odbc? ( dev-db/unixODBC )
- openssl? ( dev-libs/openssl )
- postgres? ( dev-db/postgresql )
- sqlite? ( dev-db/sqlite:3 )"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-2.4.2
- doc? ( app-doc/doxygen )"
-
-DOCS=(CHANGES NOTICE README)
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.5.3-sysroot.patch #385775
- eautoreconf
- elibtoolize
-}
-
-src_configure() {
- local myconf=()
-
- tc-is-static-only && myconf+=( --disable-util-dso )
-
- if use berkdb; then
- local db_version
- db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
- db_version="$(db_ver_to_slot "${db_version}")"
- db_version="${db_version/\./}"
- myconf+=(
- --with-dbm=db${db_version}
- # We use $T for the libdir because otherwise it'd simply be the normal
- # system libdir. That's pointless as the compiler will search it for
- # us already. This makes cross-compiling and such easier.
- --with-berkeley-db="${SYSROOT}$(db_includedir 2>/dev/null):${T}"
- )
- else
- myconf+=( --without-berkeley-db )
- fi
-
- if use nss || use openssl ; then
- myconf+=( --with-crypto ) # 518708
- fi
-
- econf \
- --datadir="${EPREFIX}"/usr/share/apr-util-1 \
- --with-apr="${SYSROOT}${EPREFIX}"/usr \
- --with-expat="${EPREFIX}"/usr \
- --without-sqlite2 \
- $(use_with freetds) \
- $(use_with gdbm) \
- $(use_with ldap) \
- $(use_with mysql) \
- $(use_with nss) \
- $(use_with odbc) \
- $(use_with openssl) \
- $(use_with postgres pgsql) \
- $(use_with sqlite sqlite3) \
- "${myconf[@]}"
- # Use the current env build settings rather than whatever apr was built with.
- sed -i -r \
- -e "/^(apr_builddir|apr_builders|top_builddir)=/s:=:=${SYSROOT}:" \
- -e "/^CC=/s:=.*:=$(tc-getCC):" \
- -e '/^(C|CPP|CXX|LD)FLAGS=/d' \
- -e '/^LTFLAGS/s:--silent::' \
- build/rules.mk || die
-}
-
-src_compile() {
- emake
- use doc && emake dox
-}
-
-src_install() {
- default
-
- find "${ED}" -name "*.la" -delete
- find "${ED}usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -delete
- use static-libs || find "${ED}" -name "*.a" -delete
-
- use doc && dohtml -r docs/dox/html/*
-
- # This file is only used on AIX systems, which Gentoo is not,
- # and causes collisions between the SLOTs, so remove it.
- rm -f "${ED}usr/$(get_libdir)/aprutil.exp"
-}