summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.13.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index da2307744b93..a680fad1da6a 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1 +1,2 @@
DIST cacti-spine-1.2.12.tar.gz 107512 BLAKE2B 1ced87c30d26d524ce9c98508cfee42dfccceac9e68662fbf31e257ebb8990bfd4935a735554ba3153f8382ada1fea86fb4712811857a09a49bec609a41aae5b SHA512 382a456bc64f4bfd56db8e6fcc2e626d66d529bbb6bfa34210053e64f9b61ae1376c9a4870402e7ccb069c20f91a85dbf5b4ec72826a1f3d70f2e6900accc0c3
+DIST cacti-spine-1.2.13.tar.gz 107543 BLAKE2B e0de75688334d27604a76c00a09ac53587a1e57f45df925e30a1a88a5e0449df803dfad901328c65b55484bc9022bf81d53880f17d4bd4efd9214315f01f7e92 SHA512 86d44195847c7b3acb1f6aed2bd6a57f562645b20724560d6b4bf7962707be4eb2f5326731453937b64420b5d51b714aecbd8dbea58d95f29ef4341515df8b00
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.13.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.13.ebuild
new file mode 100644
index 000000000000..a5c1da23c064
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+CDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0=
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}