summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-games/poker-eval/poker-eval-138.0.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-games/poker-eval/poker-eval-138.0.ebuild b/dev-games/poker-eval/poker-eval-138.0.ebuild
index c34ff4181418..415cd26152e0 100644
--- a/dev-games/poker-eval/poker-eval-138.0.ebuild
+++ b/dev-games/poker-eval/poker-eval-138.0.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit ltprune
+EAPI=7
DESCRIPTION="A fast C library for evaluating poker hands"
HOMEPAGE="http://gna.org/projects/pokersource/"
@@ -11,16 +10,16 @@ SRC_URI="http://download.gna.org/pokersource/sources/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="static-libs"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO WHATS-HERE )
src_configure() {
econf \
--without-ccache \
- $(use_enable static-libs static)
+ --disable-static
}
src_install() {
- DOCS="AUTHORS ChangeLog NEWS README TODO WHATS-HERE" \
- default
- prune_libtool_files
+ default
+ find "${ED}" -name '*.la' -delete || die
}