summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/asio/Manifest1
-rw-r--r--dev-cpp/asio/asio-1.13.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index 918fc764c059..8de840273b13 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,3 +1,4 @@
DIST asio-1.10.8.tar.bz2 1270332 BLAKE2B 97e4a6a7c8b4562f10af1d122e9b08c12d567fd0447d1951a907f47f77832dcd42df4cb9b5b392feaaa2ea7c79d8bedfcf12e3052957ec012d8bb6b4d1347eb5 SHA512 d870686d2b19bec9925c311f2f0fd370e9797bbad252176a80a998f9c322ecd502b5081826105712e7caf87c03c3e6b70a0e219019e5bff46077d6e8c3c6db09
DIST asio-1.12.1.tar.bz2 1444246 BLAKE2B d59b47a4dedd8d0892ace6d93c371cb02e16534b41bd490a945785526ad0a11bd6cb15f205bc5702b5a14780876bd92041bffac2898658b40c78ea27d4f37b14 SHA512 a994e1ee9a252d9f8cc2ada0915a9866eeebdd2b1d9a8fd50fa8db06d5ee6277f44a0f83c79f46f939adca43e02373ffee78ff6b1d6ae1798dcb1cd6d56dc568
DIST asio-1.12.2.tar.bz2 1437221 BLAKE2B c4479b66cff7811aa7b7dbe65684d2a11fb675df53e9554c2871fd4e3a8e32d262ae701e98198d508f89463da48d4509f12e8db87d033a91d55e00609207a351 SHA512 7ce2c9e846059a2205eca6bde285eab81164fbe087d51d35a33a07be6208049fcf07fc1ac33934a758b6b5907e56f3377e20bff10ffc9268376f81c6fae4e34a
+DIST asio-1.13.0.tar.bz2 1472744 BLAKE2B 1fde414bfc782f25f8ad7d7caf9ac8971bea22ebd3b74846584a242d7df164895759b74777b2330aa98d34c5b8c34f266a2f85fcc27413990cc05420f7685398 SHA512 30b09c6656c9beaf091e72d518930bb5650f4bf66b286d11457a949a690a2b9ddcad0c95cb2098b41a2226f354741755ffbc92098f2844f3253e1921ff60cd5b
diff --git a/dev-cpp/asio/asio-1.13.0.ebuild b/dev-cpp/asio/asio-1.13.0.ebuild
new file mode 100644
index 000000000000..fe556e8cbee7
--- /dev/null
+++ b/dev-cpp/asio/asio-1.13.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples libressl ssl test"
+
+RDEPEND="dev-libs/boost
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}