summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xsnow/Manifest1
-rw-r--r--x11-misc/xsnow/xsnow-3.2.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/xsnow/Manifest b/x11-misc/xsnow/Manifest
index db88e7afa7eb..f1e091bf4e35 100644
--- a/x11-misc/xsnow/Manifest
+++ b/x11-misc/xsnow/Manifest
@@ -1 +1,2 @@
DIST xsnow-3.0.7.tar.gz 322314 BLAKE2B 21c754daddb989a2f0771199d15342d0c08d23669525bbd9672537c200f7ff06d92708c256f2f89b483bb91947374195e4e95c2291425e630883cfe3b9898563 SHA512 1bc58d8c4542839ccc80c7612e472754f7471d2d72c61785b27d8a89d5e6826d40b892628bcea8c7dcfcf22e4c13db76a825a8c580a32f1ea74785f6c478fb79
+DIST xsnow-3.2.2.tar.gz 410575 BLAKE2B 212eec5744657ece2393c92c8210df23a323deb86e58cba7ecce191da23ee094590603cb267c8325ba8915a386325561ecbc165e27acf442426374abd113c441 SHA512 767aad07834b5af0be08f2e0f205cb4bb796b4ecfd4c38a187fea26b4d8c752d231a1f870494ba70b3437e54e8b5f0f745b69aa45f99d7b32d52a0d4b4cc8ba0
diff --git a/x11-misc/xsnow/xsnow-3.2.2.ebuild b/x11-misc/xsnow/xsnow-3.2.2.ebuild
new file mode 100644
index 000000000000..1ff2e5e3a1ba
--- /dev/null
+++ b/x11-misc/xsnow/xsnow-3.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools xdg
+
+DESCRIPTION="let it snow on your desktop and windows"
+HOMEPAGE="https://janswaal.home.xs4all.nl/Xsnow/ https://sourceforge.net/projects/xsnow/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ sys-apps/dbus
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXpm
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.7-gamesdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}