summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/cacti/Manifest1
-rw-r--r--net-analyzer/cacti/cacti-1.2.21.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index a9a516f29117..860499480ba0 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,3 +1,4 @@
DIST cacti-1.2.17.tar.gz 38344112 BLAKE2B e555fc99560d10e94181c38b50e6f839532fb3dc66ff688b36a7efd10c15304e7636c9b4b483763fcea751317bcb283bb2bd8f813d5759c98aed6bbf02fd256a SHA512 94ae75b2494a91c536906c7bbeaa948d16c7ad96ed3a62c1eb21175f92c01787c6849960bbc791e04b3df46edbfd3cd787eb825bb423ce0814c0904edb2c915d
DIST cacti-1.2.19.tar.gz 38477886 BLAKE2B 7d72ecd376c633f1a4e46d3ed69977eb4d342deb900aabcbccbe6213368d67f75909f55c5e1bf21dcd8e422b4504dc1a25a63fe7cf26394d4b43a35db0cedce3 SHA512 076397f4cf048dac6e0c9bb8a4889ba94ca9e40c4d53c2c142ed9e19c7a0dc5c5aa8e2321563b914635a753b59b215926a1a73723fa41d1006473cc34667ad70
DIST cacti-1.2.20.tar.gz 40715952 BLAKE2B 5cf85d075a69b3242d04df099fa5a48401d5f138bc71d71aa47bc6331b4db5b76a71c6c6a56ad4098efe7a064b7d75cd8998b13317b265afbf4238fe9d0b7f3a SHA512 b708f4431bc27baa839df6b00a4e582577a328e3aff2b55abfba38863de776371f9ba86b58582baf98db73e2b7cf1d68bbaf3a0996fa8fc91c4811fda637050c
+DIST cacti-1.2.21.tar.gz 40798454 BLAKE2B 86eae6743c07e45b4b06202cca072a385f45d2021159f0f5160a8c2a8eb8f3a2f9db63512515602d1c3eb6be4b53f5755c20d6da2194ff445c133a2bcdb33e27 SHA512 084ff9135dd0a92596a4d65f2fd461c8e84907ff87e467f6d144ee3b52ef7aeb44ffa5a8c25e74e5ff25588bc6c5b13b44ab2f24ef5e1c6652513b5c2a39f78d
diff --git a/net-analyzer/cacti/cacti-1.2.21.ebuild b/net-analyzer/cacti/cacti-1.2.21.ebuild
new file mode 100644
index 000000000000..831a6dd6858f
--- /dev/null
+++ b/net-analyzer/cacti/cacti-1.2.21.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edos2unix webapp
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="https://www.cacti.net/"
+SRC_URI="https://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+need_httpd
+
+RDEPEND="
+ dev-lang/php[cli,mysql,pdo,session,sockets,xml]
+ dev-php/adodb
+ net-analyzer/rrdtool[graph]
+ virtual/cron
+ snmp? ( >=net-analyzer/net-snmp-5.2.0 )
+"
+
+src_compile() { :; }
+
+src_install() {
+ dodoc CHANGELOG
+ dodoc -r docs
+ mv docs .. || die
+
+ webapp_src_preinst
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${ED}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}