summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/arprec/arprec-2.2.18.ebuild14
-rw-r--r--sci-libs/arprec/files/arprec-2.2.18-gold.patch15
-rw-r--r--sci-libs/arprec/metadata.xml20
3 files changed, 36 insertions, 13 deletions
diff --git a/sci-libs/arprec/arprec-2.2.18.ebuild b/sci-libs/arprec/arprec-2.2.18.ebuild
index ef5837cd07ba..99d5159a9e38 100644
--- a/sci-libs/arprec/arprec-2.2.18.ebuild
+++ b/sci-libs/arprec/arprec-2.2.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -7,7 +7,7 @@ EAPI=6
FORTRAN_NEEDED=fortran
FORTRAN_STANDARD=90
-inherit fortran-2
+inherit autotools fortran-2
DESCRIPTION="Arbitrary precision float arithmetics and functions"
HOMEPAGE="http://crd-legacy.lbl.gov/~dhbailey/mpdist/"
@@ -21,7 +21,15 @@ IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 doc fortran qd static-libs"
DEPEND="qd? ( sci-libs/qd[fortran=] )"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${PN}-2.2.18-fix-c++14.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.18-fix-c++14.patch
+ "${FILESDIR}"/${P}-gold.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
econf \
diff --git a/sci-libs/arprec/files/arprec-2.2.18-gold.patch b/sci-libs/arprec/files/arprec-2.2.18-gold.patch
new file mode 100644
index 000000000000..293b495f10a7
--- /dev/null
+++ b/sci-libs/arprec/files/arprec-2.2.18-gold.patch
@@ -0,0 +1,15 @@
+ fortran/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/fortran/Makefile.am b/fortran/Makefile.am
+index 8eb4d19..91a125c 100644
+--- a/fortran/Makefile.am
++++ b/fortran/Makefile.am
+@@ -4,6 +4,7 @@ LDADD = libarprec_f_main.la libarprecmod.la $(top_builddir)/src/libarprec.la $(F
+
+ lib_LTLIBRARIES = libarprecmod.la libarprec_f_main.la
+ libarprecmod_la_SOURCES = f_mp.cpp mp_mod.f mp_modm.f mp_modx.f
++libarprecmod_la_LIBADD = $(top_builddir)/src/libarprec.la $(FCLIBS)
+ libarprec_f_main_la_SOURCES = main.cpp
+
+ if UPCASE_MODULE
diff --git a/sci-libs/arprec/metadata.xml b/sci-libs/arprec/metadata.xml
index d4b71b40e61d..55cd058d02de 100644
--- a/sci-libs/arprec/metadata.xml
+++ b/sci-libs/arprec/metadata.xml
@@ -2,17 +2,17 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>grozin@gentoo.org</email>
- <name>Andrey Grozin</name>
-</maintainer>
-<maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
</maintainer>
-<longdescription>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
Arbitrary precision library for float arithmetics and mathematical functions.
</longdescription>
-<use>
- <flag name="qd">Use <pkg>sci-libs/qd</pkg> for quad-double datatype</flag>
-</use>
+ <use>
+ <flag name="qd">Use <pkg>sci-libs/qd</pkg> for quad-double datatype</flag>
+ </use>
</pkgmetadata>