summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/lbreakout/lbreakout-010315-r1.ebuild38
1 files changed, 26 insertions, 12 deletions
diff --git a/games-arcade/lbreakout/lbreakout-010315-r1.ebuild b/games-arcade/lbreakout/lbreakout-010315-r1.ebuild
index 4a465d929cfc..a00036389b17 100644
--- a/games-arcade/lbreakout/lbreakout-010315-r1.ebuild
+++ b/games-arcade/lbreakout/lbreakout-010315-r1.ebuild
@@ -1,30 +1,44 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit desktop toolchain-funcs
DESCRIPTION="Breakout clone written with the SDL library"
HOMEPAGE="http://lgames.sourceforge.net/LBreakout/"
SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=">=media-libs/libsdl-1.1.5"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ acct-group/gamestat
+ media-libs/libsdl[sound,video]"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( lbreakout/manual/. )
src_prepare() {
default
- sed -i \
- -e '/^sdir=/s:$datadir/games:$datadir:' \
- -e '/^hdir=/s:/var/lib/games:$localstatedir:' \
- configure \
- || die "sed failed"
+
+ # remove /games from datadir, and use /var/games for highscore file
+ sed -e '/^sdir=/s|/games.*||;' \
+ -e "/^hdir=/s|=.*|=${EPREFIX}/var/games|" \
+ -i configure || die
+
+ tc-export CC CXX
}
src_install() {
- HTML_DOCS="lbreakout/manual/*"
+ dodir /var/games #655000
+
default
+
+ fowners :gamestat /usr/bin/${PN} /var/games/${PN}.hscr
+ fperms g+s /usr/bin/${PN}
+ fperms 660 /var/games/${PN}.hscr
+
+ make_desktop_entry ${PN} LBreakout applications-games
}