summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/adobe-flash/Manifest4
-rw-r--r--www-plugins/adobe-flash/adobe-flash-32.0.0.403.ebuild141
2 files changed, 145 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/Manifest b/www-plugins/adobe-flash/Manifest
index da4eeededd2f..c88299e16c34 100644
--- a/www-plugins/adobe-flash/Manifest
+++ b/www-plugins/adobe-flash/Manifest
@@ -2,3 +2,7 @@ DIST adobe-flash-32.0.0.387-npapi.i386.tar.gz 8546104 BLAKE2B ec878a2150261bc6db
DIST adobe-flash-32.0.0.387-npapi.x86_64.tar.gz 9065685 BLAKE2B 77dd406107f42c9c8195f33e6b2eb90473dce88aa2756e0fb7c303a6ae3534d0a81a229af3dbec370281658efddd3e00fc620797eabbeaed761183b34c3553c8 SHA512 a72983efd3ef953807be0dfc5c2f22d3f25a059bc2c41b463874d7174eb44ca0dcd4d30ac04054292670e0d1894e7aff9561dbdc18b6856e067c95ef05c44f19
DIST adobe-flash-32.0.0.387-ppapi.i386.tar.gz 8832916 BLAKE2B cb83cbea7b378117470ad39d3685f01b42d9f1a54c4ab83320769e51258caf65ac0bd536f2d896375074cc5ee3c316b5aa8fb9379f6717455babd5a8dec50aaa SHA512 c28dc82ec987cb74970710f3b2404ab90623030947e57e341b31d853fb28e8a220c7877f331729139ca01b8b0c0a4c29ab4b48c635bcf2417562c842a486dd28
DIST adobe-flash-32.0.0.387-ppapi.x86_64.tar.gz 9765972 BLAKE2B e6f001cd38f823071190b9773b65cfe68efefe1c6c0f3082ccab3cb57fb9c29bb9974c147f33daa4c6b1499000256568b47f333b951ca19d595844ee03f40b13 SHA512 dd3a26a650a8620ea2aec730f1ae61c1df018461190ee09e2ac783bec79018e649add87b3e2f682fe863fdc8d9be0469fbd563d4e7dbd4d51b164fae2fcf98dd
+DIST adobe-flash-32.0.0.403-npapi.i386.tar.gz 8546310 BLAKE2B a1d14625061fa84ee79cfbf6c47a31aedccc8d707dc1f3dc140e65afc8f861236b6c2e9c3094b8a104eba0c45f3155e556fa3401a009f98043eaa299334bdd63 SHA512 666f546b6ca4b4c9f84ef07792c9c61825078f9d67f7b6039b4d40f1fdeaa0dfe3aa768190a19d850a72f7b3ed22750b3c5e1d43e47a953ec4dc8ac2a0c93bc8
+DIST adobe-flash-32.0.0.403-npapi.x86_64.tar.gz 9066221 BLAKE2B fbb758becb91ffd0c5700a313586fe17d48962bed7e0f4f6acd2a79f4716fbf47aa742983b7cfa8b9d9ef92ff729cf399fb2e2bf95da72f46f2eb73d2389d796 SHA512 a9341be933a237787af63fd2d08ca63a2da7e04069c9304f48ef374d057db314a35594e6e8806c46f7415f28a37697f2ac9aaedb88770de76c49ca43f374b68e
+DIST adobe-flash-32.0.0.403-ppapi.i386.tar.gz 8833086 BLAKE2B 98d165603fd8991f558b0cd0f11886269d99c1ae5bc4699e6d0413a9cabee0cf98906839766c92ffd75d2e16dad91b36f3c28592340c9bea805ab9f7cffe7b6e SHA512 3b0140e026022a82dd20ed69d440c4a87d252bb19321d6716e493277874d3d3c774f99fd76f20bfbd40c643b7848e7659f369555d215fe1e9974fb614a9deee7
+DIST adobe-flash-32.0.0.403-ppapi.x86_64.tar.gz 9766272 BLAKE2B b33d390415fc98c45b784c02e6deb048b489296646a4f2189c2b9ff38c6cb4acd2fa0c62b2c46c1d775fe2f151345b79e89eba9f806a8f4d5b03de1e801b328f SHA512 08e4a4e94353c5b6fb8eda90f2b82214d7d1fa7e0660071f54e6c4fe1f9f0d46018a68bb5d702e4d36398d6944a381dece9e27806a06d494b9ae1d5eba990050
diff --git a/www-plugins/adobe-flash/adobe-flash-32.0.0.403.ebuild b/www-plugins/adobe-flash/adobe-flash-32.0.0.403.ebuild
new file mode 100644
index 000000000000..4bed41bad555
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-32.0.0.403.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit xdg-utils nsplugins multilib multilib-minimal
+
+DESCRIPTION="Adobe Flash Player"
+HOMEPAGE="
+ https://www.adobe.com/products/flashplayer.html
+ https://get.adobe.com/flashplayer/
+ https://helpx.adobe.com/security/products/flash-player.html
+"
+
+AF_URI="https://fpdownload.adobe.com/pub/flashplayer/pdc/${PV}"
+AF_NP_32_URI="${AF_URI}/flash_player_npapi_linux.i386.tar.gz -> ${P}-npapi.i386.tar.gz"
+AF_NP_64_URI="${AF_URI}/flash_player_npapi_linux.x86_64.tar.gz -> ${P}-npapi.x86_64.tar.gz"
+AF_PP_32_URI="${AF_URI}/flash_player_ppapi_linux.i386.tar.gz -> ${P}-ppapi.i386.tar.gz"
+AF_PP_64_URI="${AF_URI}/flash_player_ppapi_linux.x86_64.tar.gz -> ${P}-ppapi.x86_64.tar.gz"
+
+IUSE="+nsplugin +ppapi"
+REQUIRED_USE="
+ || ( nsplugin ppapi )
+"
+
+SRC_URI="
+ nsplugin? (
+ abi_x86_32? ( ${AF_NP_32_URI} )
+ abi_x86_64? ( ${AF_NP_64_URI} )
+ )
+ ppapi? (
+ abi_x86_32? ( ${AF_PP_32_URI} )
+ abi_x86_64? ( ${AF_PP_64_URI} )
+ )
+"
+SLOT="22"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-11.x"
+RESTRICT="bindist mirror strip"
+
+NPAPI_RDEPEND="
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ >=sys-libs/glibc-2.4
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ !www-plugins/chrome-binary-plugins[flash(-)]
+ nsplugin? (
+ ${NPAPI_RDEPEND}
+ !www-plugins/adobe-flash:0
+ )
+"
+
+S="${WORKDIR}"
+
+# Ignore QA warnings in these closed-source binaries, since we can't fix them:
+QA_PREBUILT="usr/*"
+
+src_unpack() {
+ local files=( ${A} )
+
+ multilib_src_unpack() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ # we need to filter out the other archive(s)
+ local other_abi
+ [[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
+ unpack ${files[@]//*${other_abi}*/}
+ }
+
+ multilib_parallel_foreach_abi multilib_src_unpack
+}
+
+multilib_src_install() {
+ local pkglibdir=lib
+ [[ -d usr/lib64 ]] && pkglibdir=lib64
+
+ if use nsplugin; then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe libflashplayer.so
+
+ if multilib_is_native_abi; then
+ # No KDE applet, so allow the GTK utility to show up in KDE:
+ sed \
+ -i usr/share/applications/flash-player-properties.desktop \
+ -e "/^NotShowIn=KDE;/d" || die
+
+ # The userland 'flash-player-properties' standalone app:
+ dobin usr/bin/flash-player-properties
+
+ # Icon and .desktop for 'flash-player-properties'
+ insinto /usr/share
+ doins -r usr/share/{icons,applications}
+ dosym ../icons/hicolor/48x48/apps/flash-player-properties.png \
+ /usr/share/pixmaps/flash-player-properties.png
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+ fi
+
+ if use ppapi; then
+ exeinto /usr/$(get_libdir)/chromium/PepperFlash
+ doexe libpepflashplayer.so
+ insinto /usr/$(get_libdir)/chromium/PepperFlash
+ doins manifest.json
+
+ if multilib_is_native_abi; then
+ dodir /etc/chromium
+ sed "${FILESDIR}"/pepper-flash-r1 \
+ -e "s|@FP_LIBDIR@|$(get_libdir)|g" \
+ -e "s|@FP_PV@|${PV}|g" \
+ > "${D}"/etc/chromium/pepper-flash \
+ || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}