summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/notmuch/Manifest1
-rw-r--r--net-mail/notmuch/notmuch-0.24.ebuild201
2 files changed, 0 insertions, 202 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
index c5ffaddfb295..37aa54914f0a 100644
--- a/net-mail/notmuch/Manifest
+++ b/net-mail/notmuch/Manifest
@@ -1,4 +1,3 @@
DIST database-v1.tar.xz 204876 SHA256 4299e051b10e1fa7b33ea2862790a09ebfe96859681804e5251e130f800e69d2 SHA512 e2d87373e00b65756d7fea40c54fb236d7a37ce839145c3afd99ab26efdc17796e540c021e2c24e521df2d0a01ccbf918994f87a0d83235ff9b109a51555b3d0 WHIRLPOOL c3a4d99405ce5143ee2ac0cbdebdabbee0213ecfcb25615612b1577165547dd7c5b6b1d1930302dc3a8afc92b3691a6a4cc48255e91b08a297f9d2510e789233
DIST notmuch-0.23.7.tar.gz 692230 SHA256 f11bb10d71945f6c3f16d23117afc70810aa485878e66bb4bf43cc3f08038913 SHA512 e71da3bd6ce1b344aae79b277b695a4668d4fe1b8838618d6970a0b27df9867bac66a3240473ef31fc30ed8af2b0a558203ed5ffb34da873c991b1ecc6c08522 WHIRLPOOL 0b14cd6fb2b584b27b7893bb9c45724725069a6bc980cfe52f80ec3f6ec95c3a8f631975875f44b46b2799d5a0c31a62ff845b2400b7389cd8aa6f55361a0851
DIST notmuch-0.24.1.tar.gz 709190 SHA256 fa117de2c6096dd896a333b9c770572a939e04a02abe6745b6b07f5363063ca3 SHA512 e2014380de68de3e1a3fd3058a441c6771a92bfffe07c0bd2b374802dd8b2539eddbbb91074738f58f48452a936f2f9427fadca825a165c61a27fe0c3e1fe7fc WHIRLPOOL 75904127fb33ce011aaa22a1c86ac58375c1f8881a1cf384254d5adb7c13316c28436d622c760d8dec150b7442ded475b6f80c5991c5654ca418cd875e9a743b
-DIST notmuch-0.24.tar.gz 708243 SHA256 f7e44cf67630669d3537c4febd7685ca27d62a134e42f9a5db90d5a6ed4c75fc SHA512 f966b4faf96b165cc04be15a90681fabfe7ce66a0a9255183f9e4542556836adb7acfe8c02033db3ad8af6cb8962d1a64da8cdd03a0485b104a7b40b88b598d5 WHIRLPOOL a64643461bb3f4e97459b76c43700cce5f69d4e9df99c9eadd424f9d8e1fe2f3b8d33cfd19cb2945050bc5018d2a2dabe484723d68fb247084e729f0b778908b
diff --git a/net-mail/notmuch/notmuch-0.24.ebuild b/net-mail/notmuch/notmuch-0.24.ebuild
deleted file mode 100644
index de47cbb850d8..000000000000
--- a/net-mail/notmuch/notmuch-0.24.ebuild
+++ /dev/null
@@ -1,201 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
- distutils-r1 toolchain-funcs
-
-DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
-HOMEPAGE="http://notmuchmail.org/"
-SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz
- test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
-
-LICENSE="GPL-3"
-# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
-# meant to be binary backward compatible.
-SLOT="0/4"
-KEYWORDS="~alpha ~amd64 ~x86"
-REQUIRED_USE="
- nmbug? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- test? ( crypt emacs python valgrind )
- "
-IUSE="crypt doc emacs mutt nmbug python test valgrind"
-
-CDEPEND="
- !!<app-shells/bash-completion-1.9
- >=dev-libs/glib-2.22:2
- >=dev-libs/gmime-2.6.20-r2:2.6
- >=dev-libs/xapian-1.2.7-r2:=
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=sys-libs/zlib-1.2.5.2
- sys-libs/talloc
- crypt? ( >=dev-libs/gmime-2.6.20-r2:2.6[smime] )
- emacs? ( >=virtual/emacs-23 )
- python? ( ${PYTHON_DEPS} )
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
- >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb
- crypt? ( app-crypt/gnupg dev-libs/openssl ) )
- valgrind? ( dev-util/valgrind )
- "
-RDEPEND="${CDEPEND}
- crypt? ( app-crypt/gnupg )
- nmbug? ( dev-vcs/git )
- mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
- dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
- virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
- virtual/perl-Pod-Parser )
- "
-
-DOCS=( AUTHORS NEWS README )
-SITEFILE="50${PN}-gentoo.el"
-MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
-
-bindings() {
- local ret=0
-
- if use $1; then
- pushd bindings/$1 || die
- shift
- "$@"
- ret=$?
- popd || die
- fi
-
- return $ret
-}
-
-pkg_pretend() {
- if has_version '<net-mail/notmuch-0.18'; then
- ewarn
- ewarn "There are few not backward compatible changes between"
- ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
- ewarn "(0.18 section) for details before first use!"
- ewarn
- fi
-}
-
-pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
-}
-
-src_unpack() {
- unpack "${P}".tar.gz
- if use test; then
- mkdir -p "${S}"/test/test-databases || die
- cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
- fi
-}
-
-src_prepare() {
- default
-
- bindings python distutils-r1_src_prepare
- bindings python mv README README-python || die
- mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
-
- # assure that new Makefile.config will be generated
- rm -f Makefile.config || die
-
- if use test; then
- append-cflags -g
- append-cxxflags -g
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- --bashcompletiondir="$(get_bashcompdir)"
- --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
- --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
- --without-desktop
- --without-ruby
- --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
- $(use_with emacs)
- $(use_with doc api-docs)
- )
- tc-export CC CXX
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- V=1 default
- bindings python distutils-r1_src_compile
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- emake notmuch-mutt.1
- popd || die
- fi
-
- if use doc; then
- pydocs() {
- pushd docs || die
- emake html
- rm -r html/_sources || die
- rm html/{objects.inv,.buildinfo} || die
- mkdir -p ../html && mv html ../html/python || die
- popd || die
- }
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
- fi
-}
-
-src_test() {
- pax-mark -m notmuch
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
- pax-mark -ze notmuch
-}
-
-src_install() {
- default
-
- if use emacs; then
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-
- if use nmbug; then
- dobin devel/nmbug/nmbug
- dobin devel/nmbug/notmuch-report
- fi
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- dobin notmuch-mutt
- doman notmuch-mutt.1
- insinto /etc/mutt
- doins notmuch-mutt.rc
- dodoc README-mutt
- popd || die
- fi
-
- DOCS="" bindings python distutils-r1_src_install
- use doc && bindings python dodoc -r html
-}
-
-pkg_preinst() {
- if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
- elog "To enable notmuch support in mutt, add the following line into"
- elog "your mutt config file, please:"
- elog ""
- elog " source /etc/mutt/notmuch-mutt.rc"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}