summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/httpretty/Manifest1
-rw-r--r--dev-python/httpretty/httpretty-0.8.14.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/httpretty/Manifest b/dev-python/httpretty/Manifest
index 71be5aee824a..3b957d22e487 100644
--- a/dev-python/httpretty/Manifest
+++ b/dev-python/httpretty/Manifest
@@ -1,3 +1,2 @@
-DIST httpretty-0.8.14.tar.gz 43574 BLAKE2B 4015bb234c2fe3017a43fff6e3b51a7f015d9d133756d4326750da1ea06ce1910d91d7b47625a08ec85856d156a0d8b3b18706e582578e3d186994b8e4f55c69 SHA512 5adab6450e8360cc21bab4136f64cd11757b9f292c7e27980fe2561f3e705baf4f0211b9e6ff4ec9ba96a788a6c5b5b1d26657972b67423c9c25491927b0884b
DIST httpretty-0.9.6.tar.gz 7147633 BLAKE2B e1d02ddfce5ca987c6ef1a17723544f86a8573c2a6a26ec197072021e52015efce5064af21bfbe1ec03f3ac11c21717a80f114b5be2526b113e3bc0a608702f4 SHA512 bc1c64d34370209c732bc12dd9935600b647507ab2c8f18c85f348e9b5e853618ba39e10e5a073b35036e6cbe3db2cb7a342a721d0e4affa81fe178fd0b75d92
DIST httpretty-0.9.7.tar.gz 6967749 BLAKE2B e2192871ca4f0f0c0bc7c39570251d26a6d78b6e5aabb1857df2b5c3533ae066400fca323d53e1790bfa2a1509e8ebb87d20d49659620087ca3c3765648662ec SHA512 4a1cdfc09af14ab2bc6eec84ad0905103ffb48c3154b127f646b39ff131584a52b1fd56bfe7a41959fc68d64eff94a221f9bf5a159a3dbfb3535fe4ac76c6170
diff --git a/dev-python/httpretty/httpretty-0.8.14.ebuild b/dev-python/httpretty/httpretty-0.8.14.ebuild
deleted file mode 100644
index 4726db44fe1c..000000000000
--- a/dev-python/httpretty/httpretty-0.8.14.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP client mock for Python"
-HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ~arm64 ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/nose-1.2[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- dev-python/sure[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/requests-1.1[${PYTHON_USEDEP}]
- >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
-)"
-
-#Required for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
- # https://github.com/gabrielfalcao/HTTPretty/issues/125, still occur
- # py3.4 hangs on many tests and is deemed underdone
- # Upstream does not make it clear whether py3.4 is sctually tested and supported.
- # python2.7 has substantial failure in tests/functional/test_requests.py and is removed.
- # Some tests excluded attempt connection to the network
- # On testing in the state below, py2.7 still has a tally of FAILED (failures=5)
- # that occur within the folder tests/unit which upstream should address.
- # https://github.com/gabrielfalcao/HTTPretty/issues/236 Bug #532106
-
- if python_is_python3; then
- einfo "python3* not adequately supported by th package"
- elif [[ "${EPYTHON}" == python2.7 ]]; then
- rm -f tests/functional/test_requests.py || die
- nosetests -e test_recording_calls \
- -e test_playing_calls \
- -e test_callback_setting_headers_and_status_response \
- -e test_httpretty_bypasses_when_disabled \
- -e test_using_httpretty_with_other_tcp_protocols \
- tests/unit \
- tests/functional || die "Tests failed under python2.7"
- else
- nosetests -e test_recording_calls \
- -e test_playing_calls \
- -e test_callback_setting_headers_and_status_response \
- -e test_httpretty_bypasses_when_disabled \
- -e test_using_httpretty_with_other_tcp_protocols \
- tests/unit \
- tests/functional || die "Tests failed under python3.3"
- fi
-
- rm -rf "${BUILD_DIR}"/../tests/ || die
-}