summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/roswtf/Manifest1
-rw-r--r--dev-ros/roswtf/roswtf-1.13.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/roswtf/Manifest b/dev-ros/roswtf/Manifest
index caf895619d09..4257f76db5ce 100644
--- a/dev-ros/roswtf/Manifest
+++ b/dev-ros/roswtf/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.12.7.tar.gz 974568 SHA256 4c141270c9263ba1ceb0d510f9d17bfe229530a277bfe10762e88d25f46efd38 SHA512 7cfc5bf231e8e388102f192d46bd902a2b92d4620938379b362efd250c48f317f5ba6e0aee7398c841392f56c2b79f933ad5ec60eb69492add90fa2ca86a3a8f WHIRLPOOL 7537aa5b781b3426cbaa82bdb07b117045efc3f748af7413e6b52ee63f3b401e403966afb1ea305674a5613f6a191f0afa098ad16e63267ad2ec8e3117996eb0
+DIST ros_comm-1.13.0.tar.gz 974811 SHA256 01eee591e0462e267da5c01537faf609c11497b578d4426818919514a8589ea6 SHA512 8cd0f8cb40d51293946a87da0614921150aa87d168e0d38981f0b7eef3c0f514f14ff613efd192c9c898b3a90fedd0cba21a9f337a197377fd946f427369c60b WHIRLPOOL 6054aca71a7afb0a202b2b8e7baf9b06c51e41f86da0959909bfe130a63a88c684a385b7ef6f9ed8ce2c7c766d6ef78ef83fd8bd97b0cc519717087050122307
diff --git a/dev-ros/roswtf/roswtf-1.13.0.ebuild b/dev-ros/roswtf/roswtf-1.13.0.ebuild
new file mode 100644
index 000000000000..83854977495f
--- /dev/null
+++ b/dev-ros/roswtf/roswtf-1.13.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for diagnosing issues with a running ROS system"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-util/rosdep[${PYTHON_USEDEP}]
+ dev-util/rosinstall[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"