summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/matwm2/matwm2-0.1.2_pre3-r2.ebuild (renamed from x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild)35
1 files changed, 17 insertions, 18 deletions
diff --git a/x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild b/x11-wm/matwm2/matwm2-0.1.2_pre3-r2.ebuild
index c6e017074c9d..468d8e602220 100644
--- a/x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild
+++ b/x11-wm/matwm2/matwm2-0.1.2_pre3-r2.ebuild
@@ -1,33 +1,31 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit toolchain-funcs
+EAPI=8
+
+inherit edo toolchain-funcs
MY_PV="${PV//_/}"
DESCRIPTION="Simple EWMH compatible window manager with titlebars and frames"
HOMEPAGE="https://github.com/segin/matwm2"
SRC_URI="https://github.com/segin/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}/${PN}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug xft xinerama"
-S="${WORKDIR}/${PN}-${MY_PV}/${PN}"
RDEPEND="
x11-libs/libXext
x11-libs/libX11
xft? ( x11-libs/libXft )
- xinerama? ( x11-libs/libXinerama )
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/${P}-destdir-fix.patch" )
+PATCHES=( "${FILESDIR}"/${P}-destdir-fix.patch )
src_prepare() {
default
@@ -42,24 +40,25 @@ src_configure() {
--prefix="${EPREFIX}/usr"
--mandir="${EPREFIX}/usr/share/man"
--cc="$(tc-getCC)"
- $(usex debug "--enable-debug" "")
- $(usex xft "" "--disable-xft")
- $(usex xinerama "" "--disable-xinerama")
+ $(usev debug --enable-debug)
+ $(usev !xft --disable-xft)
+ $(usev !xinerama --disable-xinerama)
)
- ./configure "${myconfigureargs[@]}" || die
+ edo ./configure "${myconfigureargs[@]}"
}
src_install() {
default
- docompress -x "${EPREFIX}/usr/share/doc/${PF}"/default_matwmrc
+ docompress -x /usr/share/doc/${PF}/default_matwmrc
dodoc default_matwmrc
insinto /usr/share/xsessions
doins "${FILESDIR}"/${PN}.desktop
- echo ${PN} > "${T}"/${PN} || die
exeinto /etc/X11/Sessions
- doexe "${T}"/${PN}
+ newexe - matwm2 <<- _EOF_
+ matwm2
+ _EOF_
}