summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ros-meta/ament_cmake/Manifest1
-rw-r--r--ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/ros-meta/ament_cmake/Manifest b/ros-meta/ament_cmake/Manifest
index 613f2bd5cee8..3441cd95576f 100644
--- a/ros-meta/ament_cmake/Manifest
+++ b/ros-meta/ament_cmake/Manifest
@@ -1,2 +1 @@
-DIST ament_cmake-0.8.1.tar.gz 57078 BLAKE2B 4c6d5c821ffef6288cdd400aa9b084fcbfb33d6c9accddd1349bd656d3b3de9e779603bdad256e3f74a292e3805f06e00ba85719f09fe441f6eecdbd236cc878 SHA512 ae6bfe95585a331055ae159f8b4363f237602ece929877766a8c8bd5bfc0b423379dee38e9fe2707f92ed9753564281be13af1202ec4e9b545d293485884f35e
DIST ament_cmake-0.9.6.tar.gz 60800 BLAKE2B 71c4e71c50b7715bb8f1b5b737ce23e30f79459a14a5866801bcb810b8fe82d807b6a4eae11de427f52c618e14ef22b7693905f1a0200cc38f0ffab1d70e80cd SHA512 c923260bbd0142ea57bf3e868e94e76020939e8ec49cbf23f14221d0048f21efed00dcdae9978e00f246725ba216c151f5d53b1cd94297b8731f53dc0e45b554
diff --git a/ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild b/ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild
deleted file mode 100644
index f6fdfb5d439e..000000000000
--- a/ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit cmake-utils python-r1
-
-ROS_PN="ament_cmake"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_cmake"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="The entry point package for the ament buildsystem"
-HOMEPAGE="https://github.com/ament/ament_cmake"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64"
-fi
-IUSE=""
-
-DEPEND="
- dev-ros/ament_cmake_core
- dev-ros/ament_cmake_export_definitions
- dev-ros/ament_cmake_export_dependencies
- dev-ros/ament_cmake_export_include_directories
- dev-ros/ament_cmake_export_interfaces
- dev-ros/ament_cmake_export_libraries
- dev-ros/ament_cmake_export_link_flags
- dev-ros/ament_cmake_libraries
- dev-ros/ament_cmake_python
- dev-ros/ament_cmake_target_dependencies
- dev-ros/ament_cmake_test[${PYTHON_USEDEP}]
- dev-ros/ament_cmake_version
- ${PYTHON_DEPS}
-
- dev-python/ament_package[${PYTHON_USEDEP}]
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
-"
-# Last batch of deps above are transitive (from ament_cmake_core) but we need this to propagate proper deps
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}