summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-apps/kdepim-runtime/files/kdepim-runtime-19.04.3-ui_lockfilepage-race-condition.patch27
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-19.04.3.ebuild2
2 files changed, 29 insertions, 0 deletions
diff --git a/kde-apps/kdepim-runtime/files/kdepim-runtime-19.04.3-ui_lockfilepage-race-condition.patch b/kde-apps/kdepim-runtime/files/kdepim-runtime-19.04.3-ui_lockfilepage-race-condition.patch
new file mode 100644
index 000000000000..850c65862be3
--- /dev/null
+++ b/kde-apps/kdepim-runtime/files/kdepim-runtime-19.04.3-ui_lockfilepage-race-condition.patch
@@ -0,0 +1,27 @@
+From 4585292dd34f894505f8fc19e2bf51263768d688 Mon Sep 17 00:00:00 2001
+From: Christophe Giboudeaux <christophe@krop.fr>
+Date: Fri, 9 Aug 2019 12:54:01 +0200
+Subject: Fix another race condition found while packaging the 19.08.0 release
+
+BUG: 410474
+FIXED-IN: 19.08.0
+
+CCMAIL: cfeck@kde.org
+---
+ resources/mbox/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/resources/mbox/CMakeLists.txt b/resources/mbox/CMakeLists.txt
+index c6fa693..c52230f 100644
+--- a/resources/mbox/CMakeLists.txt
++++ b/resources/mbox/CMakeLists.txt
+@@ -17,6 +17,7 @@ set( mboxresource_SRCS
+ # Fix a race condition. mboxresource.cpp needs compactpage.h which includes ui_compactpage.h.
+ # Make sure the ui file is generated before building the akonadi_mbox_resource target.
+ set_source_files_properties(mboxresource.cpp PROPERTIES OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/ui_compactpage.h)
++set_source_files_properties(mboxresource.cpp PROPERTIES OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/ui_lockfilepage.h)
+
+ ecm_qt_declare_logging_category(mboxresource_SRCS HEADER mboxresource_debug.h IDENTIFIER MBOXRESOURCE_LOG CATEGORY_NAME org.kde.pim.mboxresource)
+
+--
+cgit v1.1
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-19.04.3.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-19.04.3.ebuild
index 5b9598cec0a8..a187fe09102e 100644
--- a/kde-apps/kdepim-runtime/kdepim-runtime-19.04.3.ebuild
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-19.04.3.ebuild
@@ -74,6 +74,8 @@ RDEPEND="${COMMON_DEPEND}
!kde-misc/akonadi-ews
"
+PATCHES=( "${FILESDIR}/${P}-ui_lockfilepage-race-condition.patch" )
+
RESTRICT+=" test"
src_prepare() {