summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/toppler/toppler-1.1.6-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-puzzle/toppler/toppler-1.1.6-r1.ebuild b/games-puzzle/toppler/toppler-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..98307d76c751
--- /dev/null
+++ b/games-puzzle/toppler/toppler-1.1.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Reimplementation of Nebulous using SDL"
+HOMEPAGE="http://toppler.sourceforge.net/"
+SRC_URI="mirror://sourceforge/toppler/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer[vorbis]
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ econf $(use_enable nls)
+}