summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/wayv/files/wayv-0.3-autoconf.patch13
-rw-r--r--x11-misc/wayv/files/wayv-0.3-flags.patch10
-rw-r--r--x11-misc/wayv/files/wayv-0.3-fno-common.patch21
-rw-r--r--x11-misc/wayv/wayv-0.3-r3.ebuild39
4 files changed, 83 insertions, 0 deletions
diff --git a/x11-misc/wayv/files/wayv-0.3-autoconf.patch b/x11-misc/wayv/files/wayv-0.3-autoconf.patch
new file mode 100644
index 000000000000..edec6bd5974d
--- /dev/null
+++ b/x11-misc/wayv/files/wayv-0.3-autoconf.patch
@@ -0,0 +1,13 @@
+--- a/configure.in
++++ b/configure.in
+@@ -1,7 +1,7 @@
+ dnl Process this file with autoconf to produce a configure script.
+-AC_INIT(src/defines.h)
+-AM_INIT_AUTOMAKE(wayv, `cat VERSION`)
+-AM_CONFIG_HEADER(config.h)
++AC_INIT(wayv, 0.3)
++AM_INIT_AUTOMAKE
++AC_CONFIG_HEADERS(config.h)
+
+ dnl Checks for programs.
+ AC_PROG_CC
diff --git a/x11-misc/wayv/files/wayv-0.3-flags.patch b/x11-misc/wayv/files/wayv-0.3-flags.patch
new file mode 100644
index 000000000000..ac6ea62ec006
--- /dev/null
+++ b/x11-misc/wayv/files/wayv-0.3-flags.patch
@@ -0,0 +1,10 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -3,6 +3,6 @@
+ bin_PROGRAMS = wayv
+ data_DATA = wayv.conf DEFAULT.wkey
+ wayv_SOURCES = ai.c aimath.c backend.c display.c gesture.c process.c setup.c misc.c
+-CFLAGS = -Wall -O2 -DSETUPPATH=\"@datadir@\"
++AM_CFLAGS = -DSETUPPATH=\"@datadir@\"
+ wayv_LDADD = @X_LIBS@
+ wayv_LDFLAGS = -I@x_includes@ -L@x_libraries@
diff --git a/x11-misc/wayv/files/wayv-0.3-fno-common.patch b/x11-misc/wayv/files/wayv-0.3-fno-common.patch
new file mode 100644
index 000000000000..394cb67c1d6d
--- /dev/null
+++ b/x11-misc/wayv/files/wayv-0.3-fno-common.patch
@@ -0,0 +1,21 @@
+--- a/src/process.c
++++ b/src/process.c
+@@ -53,6 +53,7 @@
+ */
+ void performAction(WSETUP *wayv, WGESTURE *gesture, GDISPLAY *video, GPOINT *gpoints) {
+ int i, n, a, b;
++ pid_t child = 0;
+ char **temp, *single, *comp;
+
+ /* Action names have to be at least one character in length */
+--- a/src/process.h
++++ b/src/process.h
+@@ -27,8 +27,6 @@
+ #include "display.h"
+ #include "gesture.h"
+
+-int child;
+-
+ void performAction(WSETUP *, WGESTURE *, GDISPLAY *, GPOINT *);
+ void destroyZombies(int);
+ char **createCmdLine(char *, GDISPLAY *, GPOINT *);
diff --git a/x11-misc/wayv/wayv-0.3-r3.ebuild b/x11-misc/wayv/wayv-0.3-r3.ebuild
new file mode 100644
index 000000000000..cfda0bef6e80
--- /dev/null
+++ b/x11-misc/wayv/wayv-0.3-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Wayv is hand-writing/gesturing recognition software for X"
+HOMEPAGE="http://www.stressbunny.com/wayv"
+SRC_URI="http://www.stressbunny.com/gimme/wayv/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3-autoconf.patch
+ "${FILESDIR}"/${PN}-0.3-flags.patch
+ "${FILESDIR}"/${PN}-0.3-fno-common.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ cd doc
+ default
+ dodoc HOWTO*
+}