summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xplanetFX/Manifest1
-rw-r--r--x11-misc/xplanetFX/xplanetFX-2.6.13.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-misc/xplanetFX/Manifest b/x11-misc/xplanetFX/Manifest
index 4f9ff1c7bd43..f347c3bbed2c 100644
--- a/x11-misc/xplanetFX/Manifest
+++ b/x11-misc/xplanetFX/Manifest
@@ -1 +1,2 @@
DIST xplanetfx-2.6.12_all.tar.gz 36874773 SHA256 bae39af674fc89b3fbe07ba6271bbf0a1c2ff64bbf63f4b04ff3d6f0bcc4380c SHA512 b2d76f9a8341ab5098a3b09f27f7844673850275f4c577cef344199cdc72f93060eb05786a9111a1fb9f120d747f12cc5793dba6a249141e284a3bff59d4e0fe WHIRLPOOL 7b55425eb7d1f592defd9d47144b7cce6fec682583229e5a4e5e2f407699f17dfc6114763c8df0d5a4bff7e4da034517f02f4e0bfd92201fd4c84597e87f7908
+DIST xplanetfx-2.6.13_all.tar.gz 36874849 SHA256 ab5557555af6b5134b53174023709fff2cd64895f930b474eb695222a23c9feb SHA512 dddc3666dd0f802cafd7b917eb513dd662b94617701622eabaaff18cf9277e3faf206eb602eb2af7c117a212b14e1cdbc4a8c11bded8243571ae4afa86f3fe72 WHIRLPOOL 6e734bdcaa6be65d29e31f5659950bde310e564e19ab34a06140f002e09cf8ac75594017f3e844a7edd881a05d25cd34883f53ac8515ae5853361938b580a1b5
diff --git a/x11-misc/xplanetFX/xplanetFX-2.6.13.ebuild b/x11-misc/xplanetFX/xplanetFX-2.6.13.ebuild
new file mode 100644
index 000000000000..ef8d834ced6e
--- /dev/null
+++ b/x11-misc/xplanetFX/xplanetFX-2.6.13.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+DESCRIPTION="GUI to configure, run or daemonize xplanet with HQ capabilities"
+HOMEPAGE="http://mein-neues-blog.de/xplanetFX/"
+SRC_URI="http://repository.mein-neues-blog.de:9000/archive/${P/FX/fx}_all.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ sys-devel/bc
+ x11-misc/xplanet
+ libnotify? ( x11-libs/libnotify )"
+#python
+
+S="${WORKDIR}/usr"
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}"/${PN}-2.6.4-gentoo-path.patch
+ sed -e "s/Application;//" -i share/applications/*desktop || die
+
+ # These will be installed separately
+ mkdir gentoo || die
+ mv share/${PN}/{autostart,flipview.py,stars/catalog.py,xplanetFX_gtk,xplanetFX_tray} \
+ gentoo || die
+}
+
+src_install() {
+ dobin bin/${PN}
+ insinto /usr/share/applications
+ doins share/applications/${PN}.desktop
+ insinto /usr/share/pixmaps
+ doins share/pixmaps/*
+ insinto /usr/share/${PN}
+ doins -r share/${PN}/*
+
+ exeinto /usr/share/${PN}
+ doexe gentoo/autostart
+
+ dodoc share/doc/${PN}/{changelog,README}
+
+ python_scriptinto /usr/share/${PN}/stars
+ python_foreach_impl python_doscript gentoo/catalog.py
+ python_scriptinto /usr/share/${PN}
+ python_foreach_impl python_doscript gentoo/{xplanetFX_gtk,xplanetFX_tray}
+ python_foreach_impl python_domodule gentoo/flipview.py
+}